Jump to content


P4VS marking the solution for add

p4vs

  • Please log in to reply
5 replies to this topic

#1 Hokushin

Hokushin

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 04 March 2013 - 01:53 PM

Hi all,

Is there anyway to stop P4VS from marking the solution for add in P4VS?  If not, could this feature be added?  The way we manage our project means we don't need to check in the solution file.  P4VS automatically marking the solution for add is particularly annoying when working with Streams, especially when you are trying to copy up and it doesn't work because you have a active file in that Stream workspace.

#2 P4Matt

P4Matt

    Advanced Member

  • Members
  • PipPipPip
  • 1383 posts

Posted 06 March 2013 - 04:00 PM

Your best bet is to add your .sln file to your P4IGNORE file. In P4VS you can now right click a file, go to 'Manage Files' in the context menu, and select 'Add to Ignore List'. Perforce won't bug you about those files again. If you settle on a convention you can checkin those ignore files and share them with your co-workers.

#3 Hokushin

Hokushin

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 07 March 2013 - 10:47 AM

Oh the one thing I didn't try.  Thanks, Matt.

I did try adding the solution to the stream's Ignored list, since it would affect everyone and all streams (I did it in the mainline stream).  However, this has an unfortunate side effect of firstly bringing up a dialog box saying something like "solution is not in the client view" (or something to that effect, I can't really remember) and it also broke P4VS's ability to auto-checkout files that were being edited.

Thanks again.

#4 shalliday

shalliday

    Member

  • Members
  • PipPip
  • 12 posts
  • LocationElectronic Arts Canada

Posted 11 April 2013 - 04:08 PM

We definitely need this to work to use P4VS - I have waited over 10 minutes for the solution to open, and it is trying to add files that are not under my client-spec.  It should not require a server upgrade to configure files/directories to ignore.

#5 P4Matt

P4Matt

    Advanced Member

  • Members
  • PipPipPip
  • 1383 posts

Posted 11 April 2013 - 08:39 PM

If you are using a 12.1 server or later the ignore file approach should work. I honestly was surprised to find that P4IGNORE requires an updated server; I would have thought all that work was client side.

I haven't tried it, but it seems like you should be able to map the .sln and project files out of your workspace if you don't have access to  a server with P4IGNORE.

#6 benjaminc247

benjaminc247

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 02 December 2015 - 01:15 AM

For anyone who does not see the menu option, it is enabled by selecting "Enable Ignore Lists for specifying files to ignore when marking for add" under Tools->Options->"Source Control"->"Perforce - Ignoring Files"





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users