Jump to content


Slow P4V connectivity on Windows using VPN

connection vpn windows

  • Please log in to reply
2 replies to this topic

#1 wbahnassi

wbahnassi

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 16 March 2013 - 11:50 PM

Hello all,

I'm facing an annoying problem on machines connecting remotely to a P4 server through VPN.
My setup is a basic P4 server on Windows 8 Pro. Machines on the same local network can access the server just fine and fast. However, machines connecting to the server through VPN take ages to do any operation. For example, opening P4V takes ~2mins. Executing p4 info takes the same. It's just unnatural.

The remote machines can access the server fine and fast (e.g., accessing shared folders). It seems that only P4 is having access issues to the server.

The server is running P4D/NTX64/2012.2/551823 (2012/11/09). Clients connect to the server by specifying its IP, so it shouldn't be a DNS resolve issue.

I tried the suggestions in the KB article here, but that didn't help. Any ideas?

Best

#2 P4Matt

P4Matt

    Advanced Member

  • Members
  • PipPipPip
  • 1383 posts

Posted 20 March 2013 - 04:38 PM

Based on your description, it sure sounds like a problem with a reverse DNS lookup. p4 info in particular will do a reverse DNS lookup even if you give the IP address as the port. Your best bet is to add an entry in your hosts file; that will short circuit the rDNS lookup. I've also added you to the bug that asks for a way to disable the reverse DNS lookup on p4 info.

#3 wbahnassi

wbahnassi

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 22 March 2013 - 12:19 AM

Thank you Matt. It indeed was that, on the server side though, not the client. In the Windows hosts file on the server, I added an entry mapping the server's name to its VPN IP and that solved the problem for good. p4 info and P4V run very fast now.





Also tagged with one or more of these keywords: connection, vpn, windows

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users