Jump to content


Tried to move a file, it failed, now I can't revert

troubleshooting bug move revert

  • Please log in to reply
2 replies to this topic

#1 kwood1138

kwood1138

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 28 March 2013 - 03:18 PM

We're running server version 2009.2, I have tried using P4V versions 2010.1, 2009.2, 2009.1, 2005.1 and now 2012.3...

I tried moving several files between two folders. My changelist had the appropriately matching delete and add items for all but one file. When the changelist failed to submit, I saw that for one file, the "delete" item was marked as a part of move command (shown as a red box with a white "x"), but the "add" item was marked as a fresh add (shown as a red "plus").

I reverted everything, but the rogue "delete" item stuck around.

When I try to revert this file in p4v, it tells me that the target file (where this file was supposed to be move to) is not opened on this client.

From the command line, trying to run
p4 revert filename
tells me that file "has been moved, not reverted"


I spoke with a coworker who has become the de facto administrator. He was not able to force the revert. He suggested I try an earlier version of p4/p4v to see if there was some incompatibility. I went as far back as 2005.1 to see if running the revert before "move" was a discrete action would help me out. No dice.

What's my next move here? Get the admin to blow away my workspace?

#2 P4Matt

P4Matt

    Advanced Member

  • Members
  • PipPipPip
  • 1383 posts

Posted 28 March 2013 - 08:54 PM

I did some digging an it looks like this is an old server bug. I'm guessing that you are on 2009.1 or earlier? The easiest fix is to delete and recreate the client.

#3 mister_wilson

mister_wilson

    Advanced Member

  • Members
  • PipPipPip
  • 119 posts
  • LocationMontreal, Quebec

Posted 03 April 2013 - 01:30 AM

I had this exact same issue not long ago. I can confirm that P4Matt's suggestion was the only way I was able to solve this issue. :unsure:





Also tagged with one or more of these keywords: troubleshooting, bug, move, revert

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users