Jump to content


View in P4V with keeping UTF-8 settings

P4VS

  • Please log in to reply
2 replies to this topic

#1 Hyunjik Bae

Hyunjik Bae

    Member

  • Members
  • PipPip
  • 15 posts

Posted 23 May 2013 - 02:47 AM

Environment:
P4V and P4 Visual Studio 2012 plugin latest version.
Unicode(UTF-8) for every source file.

Problem:
When I select "View in P4V" from Visual Studio 2012, (attached image for details) a new P4V window is opened but its Connection Character Encoding becomes other than UTF-8 but system locale(Korean CP949). I want P4V opened with keeping UTF-8 settings.

How can I resolve this problem? Please reply.
Thank you in advance.

Attached Thumbnails

  • encode.jpg


#2 P4Matt

P4Matt

    Advanced Member

  • Members
  • PipPipPip
  • 1383 posts

Posted 23 May 2013 - 05:57 PM

I'll add a request for you asking to propagate the character encoding used by P4VS to P4V. It currently assumes that you want the character set to match your OS.

#3 p4bill

p4bill

    Advanced Member

  • Members
  • PipPipPip
  • 216 posts

Posted 23 May 2013 - 06:16 PM

P4VS uses the character encoding from P4CHARSET if it is set. Otherwise, it will default to the system character encoding. Is P4CHARSET set to UTF-8 on your system?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users