Jump to content


Problems with 'Reconcile Offline Work' (Mac)


  • Please log in to reply
3 replies to this topic

#1 bvanderw

bvanderw

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 05 July 2013 - 05:30 PM

I am having a couple of problems with 'Reconcile Offline Work' in P4V (2013.2) under OSX.

1) Framework bundles often have a number of symbolic links that point to other files within the Framework bundle. It appears that P4V follows the symbolic links and shows those files as 'Local files not in depot'. Can this behavior  be changed?

2) In the Filters, a Folder path can either be included or not included. This appears to require a full path name and any kind of wildcard notation does not work. I would really like to be able to filter folders recursively (this would be one solution to #1).

For example, AppCode adds a '.idea' folder to the project folder. I would really like to be able to do something like this:

/Users/<user>/<project>/.idea/...

Better yet....

.idea/...

I tried messing around with .p4ignore files, but they don't seem to make a difference in P4V (at least in this particular dialog).

Thanks....

#2 P4Matt

P4Matt

    Advanced Member

  • Members
  • PipPipPip
  • 1383 posts

Posted 05 July 2013 - 05:57 PM

Getting the ignore files to work on the Mac takes a bit of work; OS X apps can't take advantage of variables set in the bash shell, but you can set environment variables that they can read. In OS X 10.7 and below you can put environment variables in ~/.MacOSX/environment.plist and they will be accessible to GUI applications. With 10.8 you need to use launchctl instead.

Here are the details: http://stackoverflow...3756686#3756686

On point 1) I don't know of anyway to configure that behavior currently. Can you try 'p4 reconcile' from the command line and see if the behavior is the same? I suspect we'll need a flag to tell reconcile to not follow symlinks.

#3 bvanderw

bvanderw

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 05 July 2013 - 09:00 PM

Thanks Matt!

As it turns out, the server version is 2011.1, so I can't check p4 reconcile.

Does P4IGNORE also depend on a later server version? I was thinking this was a client side thing, but I haven't been able to get it to work.

I see that P4IGNORE is set to .p4ignore in the environment.

I have a .p4ignore file inside of the .idea folder with one line: *.* (I've also tried ./*), but both p4 and P4V will still add any file that is in that folder.

#4 P4Matt

P4Matt

    Advanced Member

  • Members
  • PipPipPip
  • 1383 posts

Posted 08 July 2013 - 10:42 PM

P4IGNORE does in fact need a newer client and server.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users