Jump to content


P4V Workspace Location Issue


  • Please log in to reply
4 replies to this topic

#1 SeanO'Connor

SeanO'Connor

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 26 August 2013 - 04:19 AM

Earlier today, I had test depot and workspace working perfectly (I am brand new to Perforce). After that, I deleted the tests and made the real depot and workspace only to encounter this error in the Dashboard:

P4V is having trouble translating the location "y:\PERFORCE" to a valid workspace location. To filter using this location, drag the folder from the workspace tree to the workspace folder field or include the depot location in your workspace view.

No matter what I try, I cannot get rid of it. I have deleted the cached settings in the user folder, tried many different locations for the depot and workspace, verified permissions, yet nothing seems to work.

My setup is:
Windows 7 x64 (with Perforce x64)
Perforce server is localhost
Just a single user (myself)
Perforce is installed to C:\
Depot and Workspace need to be on Y:\

Any help is greatly appreciated, thank you.

EDIT: Tried more stuff:
Completely reinstalled Perforce deleting every settings cache I could find
Tried a Sandbox instead
Edited my hosts file in Windows to use the same name as my computer
Tried on my completely separate Windows 8 x64 partition

Still nothing has changed. There must be something I am doing wrong.

#2 P4Matt

P4Matt

    Advanced Member

  • Members
  • PipPipPip
  • 1383 posts

Posted 28 August 2013 - 07:37 PM

What does your workspace view look like? Is the client root in Y:\?

#3 SeanO'Connor

SeanO'Connor

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 30 August 2013 - 07:01 AM

The client root is Y:\. I have that set in the environment variables, as well as in the workspace itself. It was also tried without any explicitly set root (that is the way it worked the first time, but not after that). I have also tried setting the workspace root to a subdirectory of Y:\ (Y:\Worspace_Name) with no luck.

The most baffling part of this is that it worked the first time, and now I hit this error on a completely different Windows install that never had Perforce on it.

#4 P4Matt

P4Matt

    Advanced Member

  • Members
  • PipPipPip
  • 1383 posts

Posted 30 August 2013 - 03:33 PM

Here are a couple things I would try:

1) Go to the command line and try some Perforce operations from Y:\ to make sure that server is setup and functioning correctly. Make sure to run 'p4 info'  and 'p4 changes'. If those return sane values you're golden.

2) If everything was fine in step 1, go to your user folder (c:\Users\<you>) and delete the .p4qt folder that you should find there. That will reset P4V to a fresh state. Then try connecting again.

#5 SirHubert

SirHubert

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 13 January 2020 - 06:19 PM

View PostP4Matt, on 30 August 2013 - 03:33 PM, said:

2) If everything was fine in step 1, go to your user folder (c:\Users\<you>) and delete the .p4qt folder that you should find there. That will reset P4V to a fresh state. Then try connecting again.

I know it's late but I wanted to thank you for that. It just saved me from the same error




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users