Jump to content


Swarm email configuration - sender email address

email

  • Please log in to reply
3 replies to this topic

#1 Tracey Bogue

Tracey Bogue

    Member

  • Members
  • PipPip
  • 14 posts

Posted 30 August 2013 - 05:58 PM

Hello,

I am setting up the Swarm OVA for a trial. I am trying to get Swarm emails properly configured. I need to be able to configure the sender email user address so that it works correctly with our server. It does not work with the default notifications@swarm.blinqnetworks.com. I don't see any option for doing this in the Swarm config.php file, and the php.ini file seems to have an option that is only used for Win32.

This is the error from the Swarm log file:

2013-08-30T13:52:30-04:00 ERR (3): exception 'Zend\Mail\Protocol\Exception\RuntimeException' with message '5.7.1 <notifications@swarm.blinqnetworks.com>: Sender address rejected: Access denied^M
' in /opt/swarm-2013.1.674419/library/Zend/Mail/Protocol/AbstractProtocol.php:351

I'd appreciate it if you could let me know how to configure the sender email address.

Thanks,

Tracey Bogue

#2 P4dmountney

P4dmountney

    Advanced Member

  • Members
  • PipPipPip
  • 44 posts
  • LocationVictoria BC

Posted 30 August 2013 - 06:10 PM

Hi Tracey,

The option for setting this in config.php is a property called 'sender' under the 'mail' configuration. The options are better documented in our upcoming release, but here is a snippet from the new doc:

<?php
	// this block should be a peer of 'p4'
	'mail' => array(
		// 'sender' => 'swarm@my.domain', // defaults to 'notifications@hostname'
		'transport' => array(
			'name' => 'localhost',		 // name of SMTP host
			'host' => '127.0.0.1',		 // host/IP of SMTP host
			'port' => 587,				 // SMTP host listening port
			'connection_class' => 'plain', // 'smtp', 'plain', 'login', 'crammd5'
			'connection_config' => array( // include when auth required to send
				'username' => 'user',	 // user on SMTP host
				'password' => 'pass',	 // password for user on SMTP host
				'ssl'	 => 'tls',	 // empty, 'tls', or 'ssl'
			),

			// override email deliveries and store all messages in this path
			// 'path' => '/var/spool/swarm',
		),

		// override regular recipients; send email only to these addresses
		// 'recipients' => array(
		//	 'user1@my.domain',
		//	 'user2@my.domain',
		// ),
	),


#3 Tracey Bogue

Tracey Bogue

    Member

  • Members
  • PipPip
  • 14 posts

Posted 30 August 2013 - 08:33 PM

Hello,

Thanks for the response. I was able to change the sender email as indicated. I am still getting the sender address rejected (access denied) error. Is there a test mail script available in the OVA to simplify testing?

Thanks,

   -tracey

#4 P4dmountney

P4dmountney

    Advanced Member

  • Members
  • PipPipPip
  • 44 posts
  • LocationVictoria BC

Posted 30 August 2013 - 09:24 PM

We don't have a test mail script, but that is a good idea. We do have the 'recipients' property that you can see above, which will at least limit who your emails are going to while you are testing.

Depending on your mail server, it may be restricting the sender address to one that actually exists, so if you aren't already using a real mail account as the sender, you probably want to try that next.



Also tagged with one or more of these keywords: email

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users