Jump to content


Authentication issue when posting test result back from Jenkins

jenkins authentication testing

  • Please log in to reply
5 replies to this topic

#1 vikerman

vikerman

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 20 September 2013 - 05:39 PM

Hi,
We are using Swarm 2013.1/674419 release.

I am trying to integrate Swarm with our Jenkins server as outlined in http://www.perforce....test_suite.html

We turned on "Require login" feature since we work from distributed locations and the swarm server is in public internet.

Everything works fine in Jenkins - except the require login seems to be an issue when posting test results from Jenkins back to the Swarm success or failure URL.

The error from curl step in the build script is

jenkins-swarm-trigger: reporting failure to [http://SWARMSERVER/r...9-B2699B314CB3/]
  % Total % Received % Xferd  Average Speed   Time Time Time  Current
Dload  Upload   Total   Spent Left  Speed

  0 0 0 0 0 0   0   0 --:--:-- --:--:-- --:--:-- 0
100   144  100 96  100 48 227 113 --:--:-- --:--:-- --:--:--  1523
{
"error": "Invalid username or password.",
"info": null,
"isValid": false,
"toolbar": null,
"user": null
}

Can the login requirements just for the test callback URLs be turned off since it already has an authentication token attached to it?

I tried some work around like logging in using curl using the --cookie-jar option and then posting to the success/failure URL using the cookie but that doesn't seem to work either.

#2 P4dmountney

P4dmountney

    Advanced Member

  • Members
  • PipPipPip
  • 44 posts
  • LocationVictoria BC

Posted 20 September 2013 - 06:14 PM

Thanks for letting us know. We've fixed this in the upcoming release, which will be out very soon.

#3 P4MarcW

P4MarcW

    Advanced Member

  • Guests
  • PipPipPip
  • 30 posts
  • LocationVictoria, BC

Posted 21 September 2013 - 04:00 AM

Hi there, Swarm 2013.2 is now available; you can browse the release notes to see the changes.

In particular:

Quote

Bugs fixed in 2013.2
...
#684802 (Bug #67816)
Fixed an issue where token-based auth (alone) wouldn't work for
deploy and automated test integration if require_login was enabled.

Apologies you had to experience this bug. I recommend you consider this new version -- we've improved the experience in a number of areas and fixed a number of bugs. Please let us know if you have any further issues.

Thanks for using Swarm!
-Marc

#4 vikerman

vikerman

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 23 September 2013 - 07:12 PM

Thanks! The bug is exactly the problem we are having. We are upgrading the Swarm server today. Will let you know if it doesn't work.

-Vikram

#5 vikerman

vikerman

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 24 September 2013 - 09:34 AM

Upgrading to 2013.2 fixed the issue. Thanks!

-Vikram

#6 P4MarcW

P4MarcW

    Advanced Member

  • Guests
  • PipPipPip
  • 30 posts
  • LocationVictoria, BC

Posted 24 September 2013 - 04:40 PM

Excellent, glad to hear it Vikram!
-Marc



Also tagged with one or more of these keywords: jenkins, authentication, testing

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users