Jump to content


No user can create workspace

P4PASSWD permissions

  • Please log in to reply
5 replies to this topic

#1 Max Pavlov

Max Pavlov

    Advanced Member

  • Members
  • PipPipPip
  • 59 posts

Posted 08 October 2013 - 10:40 PM

I've deployed commons using OVA image and have followed a standard setup procedures. Jetty, commons web site and perforce for commons all live in one virtual machine.

I've set up a login through LDAP (to our AD) and users now can login fine.

But, no user, including commonssupoer, can create a workspace.

I get the following error in response to a POST request to create a space to a corresponding api url:

{"payload":"Error in group specification.\n'CPU' validation failed: Perforce password (P4PASSWD) invalid or unset.\nError in protect specification.\nError detected at line 2.\nSyntax error in 'write'.\n","status":{"message":"Cannot create a space","code":4011}}

Please advise on where do I set the P4PASSWD since apparently it didn't get set during installation.

Thank you.

#2 P4Matt

P4Matt

    Advanced Member

  • Members
  • PipPipPip
  • 1383 posts

Posted 22 October 2013 - 06:25 AM

That particular triggers looks for the commonsuper password in /etc/p4d.conf. If you don't specify it there then you'll need to specify it in the commons_protection_updater.sh script. It's in /usr/local/bin.

#3 Max Pavlov

Max Pavlov

    Advanced Member

  • Members
  • PipPipPip
  • 59 posts

Posted 11 May 2014 - 07:11 AM

Thanks Matt. I have now made another attempt to deploy commons in an organization. I was able to create spaces just fine with an emmbedded users, but as soon as I swiched to AD authentication support, the same error started to appear whenever any user is trying to create space.

commonssuper password is set in p4d.conf


# Change the *PASS values to match set values
COMMONSSUPERPASS={mycustompass}

As well as the sae custom pass I've used for setting the commonsmgmt password:

# SET THIS PASSWORD WHEN USING AD/LDAP
COMMONSMGMTPASS={mycustompass}

If I try the set passwords in an ssh session like:

p4 -p localhost:1666 -C utf8 -u commonssuper login
Enter password: {mycustompass}
User commonssuper logged in.

Same SSH test pass for commonsmgmt user.

Yet I am still unable to create any spaces after switching to AD authentication.

P.S. As in this thread: http://forums.perfor...ork/#entry12374

I had to alter the commons_auth_check.sh and change 32 to 0 since AD returns 0 for successfull LDAP search. If that brings any help to understanding my situation of course.

#4 P4Matt

P4Matt

    Advanced Member

  • Members
  • PipPipPip
  • 1383 posts

Posted 13 May 2014 - 10:34 PM

What version of Commons are you using? We had a bug like late last year, but 2014.1 should have addressed it.

#5 Max Pavlov

Max Pavlov

    Advanced Member

  • Members
  • PipPipPip
  • 59 posts

Posted 14 May 2014 - 10:08 AM

Hi. Thanks for response.

Version: 2013.6.760204

I will now see if there is an updated version of the commons distro and will install it. Thanks.

#6 Max Pavlov

Max Pavlov

    Advanced Member

  • Members
  • PipPipPip
  • 59 posts

Posted 15 May 2014 - 09:48 AM

Yep, bug in versions prior to 2014.1. LDAP/AD basically only works in 2014 + versions of Commons.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users