Jump to content


Problem switching server to unicode


  • Please log in to reply
2 replies to this topic

#1 balintn

balintn

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 24 November 2013 - 04:09 PM

Hi!
We had some accented character translation problems in Visual Studio vdproj files.
We believe that accented characters are corrupted when checked in/out of Perforce server.
As a countermeasure, I'd like to switch our Perforce server to unicode.
I followed the instructions here: https://kb.perforce....na..tionSupport
- stopped the Perforce service
- issued p4d -xi (which stated the server was switched to unicode)
- restarted the service
However,
- when I issue "p4 counters", the unicode counter is not present
- when I try to submit a filetype change to unicode, I get the error "cannot submit unicode type file using non-unicode server"

What am I missing?
- Server is running on Windows.
- Program files / Perforce / p4.exe version is 2013.1.68.5046
- Program files / Perforce / Server / p4d.exe, p4s.exe version is 2013.1.71.548

Any help is appreciated.

#2 P4Matt

P4Matt

    Advanced Member

  • Members
  • PipPipPip
  • 1383 posts

Posted 26 November 2013 - 05:01 PM

When you run the p4d -xi make sure to specify the root using the -r flag; I have a suspicion it didn't run against the correct db files.

#3 balintn

balintn

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 28 November 2013 - 12:22 PM

Now it works (it produces the non-UTF8 errors mentioned in the How to article).
I will follow that conversion process.

In my case the problem was that $P4ROOT was not set by default.
So, this is a note to anyone with default installations: use this:
p4d -xi -r<directory of your p4d.exe>

Thanks,
B




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users