I keep getting the following error in my rails application:
SSL library must be at least version 1.0.1
Can someone please advise - exactly HOW does P4API check the version of the linked OpenSSL library?
The reason I ask - my server has OpenSSL 0.9.8 installed, but I have also built / installed 1.0.1 using RVM, and also manually from source (into a different folder). Curiously, in the case of the latter attempt, I get the following output:
[root@mars-stream14 ssl]# bin/openssl version OpenSSL 1.0.1 14 Mar 2012 [root@mars-stream14 ssl]# ls -l lib[/size] total 6932 drwxr-xr-x 2 root root 4096 Apr 11 10:20 engines -rw-r--r-- 1 root root 3822194 Apr 11 10:20 libcrypto.a lrwxrwxrwx 1 root root 18 Apr 11 10:20 libcrypto.so -> libcrypto.so.1.0.0 -r-xr-xr-x 1 root root 2126936 Apr 11 10:20 libcrypto.so.1.0.0 -rw-r--r-- 1 root root 655802 Apr 11 10:20 libssl.a lrwxrwxrwx 1 root root 15 Apr 11 10:20 libssl.so -> libssl.so.1.0.0 -r-xr-xr-x 1 root root 424791 Apr 11 10:20 libssl.so.1.0.0 drwxr-xr-x 2 root root 4096 Apr 11 09:59 pkgconfig
Clearly the exe is 1.0.1, but (based on name at least) the .so is still 1.0.0. When I link to these libraries, I still get the error from P4API, despite (to the best of my knowledge at least!) it being 1.0.1 - rather than 1.0.0 as the name suggests!
So is P4API just looking at the name libssl.so.1.0.0 and deciding it's the wrong version? Is there an issue with how OpenSSL is getting built? etc etc.
Stumped and confused!