Jump to content


Building P4Python on Raspberry Pi, getting multiple errors

p4python build raspberry pi

  • Please log in to reply
2 replies to this topic

#1 Luc Daigle

Luc Daigle

    Member

  • Members
  • PipPip
  • 10 posts

Posted 18 December 2014 - 02:39 PM

I'm attempting to build the P4Python API on a raspberry pi but am receiving multiple errors when doing so.  I'm not familiar enough with building from source to know what these errors mean (the complete output is in the attached text file).  Has anyone else attempted this and received these errors (or been successful)?

Luc

Attached File  buildoutput.txt   39.57K   309 downloads

#2 P4Lester

P4Lester

    Advanced Member

  • Members
  • PipPipPip
  • 144 posts

Posted 12 February 2015 - 02:08 AM

Hi Luc,

Can you confirm that you are using the P4API for linux26armhf (and not linux26armel)?

You can download it from:

  http://ftp.perforce....armhf/p4api.tgz

Have fun!

I work for Perforce.
Workshop | Twitter | LinkedIn | about.me


#3 Luc Daigle

Luc Daigle

    Member

  • Members
  • PipPip
  • 10 posts

Posted 12 February 2015 - 09:33 PM

That was it!  I downloaded the p4api files from the link you provided and I was able to build p4python just fine.  Thank you very much!





Also tagged with one or more of these keywords: p4python, build, raspberry pi

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users