Jump to content


Mouse wheel not working in p4v for Linux (2015 February 04 version)

linux ubuntu p4v

  • Please log in to reply
7 replies to this topic

#1 fencekicker

fencekicker

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 16 February 2015 - 01:20 PM

Hi,

I'm using p4v version 'Rev. Perforce Visual Client/LINUX26X86_64/2014.3/998867'. I tried it on both Ubuntu 12.04 and 14.04 (both 64 bit) and the mouse wheel doesn't work for me - it won't scroll either up or down. Both are running in VMs under Windows 7.

The mouse wheel works fine in other Linux apps (e.g. Konsole, emacs).

Any idea how to fix this?

#2 P4Shimada

P4Shimada

    Advanced Member

  • Members
  • PipPipPip
  • 831 posts

Posted 18 February 2015 - 11:00 PM

Hi Stefan,

Thank you for sending your P4V version. In researching online, recent versions of Ubuntu have reported scrolling issues, such as here:

    http://askubuntu.com...acle-virtualbox

- Have you checked the "Machine" menu of the Virtual machine window in which Ubuntu was running? Some sites report that you must select "Disable Mouse Integration".

- What are your mouse scroll settings? For example, Go to Unity Dash (press Super/Windows key) and search for Mouse & Touchpad

- Are you using 'guest additions'?

#3 fencekicker

fencekicker

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 19 February 2015 - 08:31 PM

HI P4Shimada, thanks for replying!

Indeed, I insisted on specifying the p4v version and the Ubuntu version, but forgot the VM platform :). It's VMWare Player 6.0.5. I am using VMWare tools (probably the equivalent of guest additions). I tried one of the suggestions from askubuntu - uninstalling and reinstalling VMWare tools, on the Ubuntu 12.04 machine, but that didn't work.

I've looked at mouse settings on 12.04 and didn't see anything suspicious; as I said, scrolling works fine in other apps. I could give WMware player 7.0 a shot, maybe...

#4 P4Shimada

P4Shimada

    Advanced Member

  • Members
  • PipPipPip
  • 831 posts

Posted 19 February 2015 - 08:56 PM

Hi Stefan,

You're welcome! Aaah okay you are using the VMWare Player 6.0.5. software. Did you check the menu settings in VMWare Player 6.0.5. for your Ubuntu instance and check/un-check any options for the mouse to see if it made a difference?  Have you tried to release the mouse by pressing Ctrl-Alt?

What are your mouse scroll settings in Ubuntu?

#5 fencekicker

fencekicker

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 20 February 2015 - 09:49 AM

In 14.04 I checked "mouse & touchpad" - see screenshot. Do you see anything unusual?

I see Player -> Manage -> Virtual Machine Settings... in the VMP menu, it seems the only place where one can set up hardware. There's nothing about the mouse there, unfortunately, there's one entry for the USB controller (see second screenshot).

In the 12.04 VM I have a Ubuntu install over which I've installed kubuntu-desktop and I'm using KDE. I've added a screenshot for that, too. The advanced tab has settings for pointer acceleration, double click interval etc.

Attached Thumbnails

  • mouse_settings_ub14.png
  • vmsettings.png
  • mouse_settings_kde1.png


#6 hwti

hwti

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 04 March 2015 - 01:48 AM

The mouse wheel is probably broken for all applications using Qt>=5.3, when they switched to xinput2.

You need an xserver-xorg-input-vmmouse package with the following commit : http://cgit.freedesk...712f7257b221370.

Unfortunately it's not part of any official release. There is an unofficial build (https://launchpad.ne....series_filter=), but only for Utopic (Ubuntu 14.10).

#7 fencekicker

fencekicker

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 12 March 2015 - 12:12 PM

hwti, thanks a lot for clarifying this. I guess using an older version of p4v with Qt < 5.3 would also get rid of this.

Are you aware of any git repository the Ubuntu guys might have for xserver? Maybe I could try applying the patch on top of that and rebuilding debs...

#8 fencekicker

fencekicker

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 12 March 2015 - 12:33 PM

Nevermind, I managed to fix this in Ubuntu 12.04. I guess something similar can be done in 14.04. I fetched the source, added the patch and rebuilt a deb package with this change.

Fetching the source involves:
$ apt-get source xserver-xorg-input-vmmouse

Then adding the patch to the list to be applied - I downloaded the patch from the above link and then saved it as xserver-xorg-input-vmmouse-12.9.0/debian/patches/02-fix-vmmouse-qt5_3.diff. Then added the patch in debian/patches/series. I then ran

dch -i

To generate a different version for the .deb (so you'd know it's different from the official deb) and then

debuild -us -uc -b

to rebuild the deb package. I got some errors about necessary build dependencies, so I had to install those and then reran the above. Then installed the resulting .deb package and voila, the mouse wheel now works with the latest p4v.

Thanks hwti!





Also tagged with one or more of these keywords: linux, ubuntu, p4v

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users