Jump to content


Adding People not working


  • Please log in to reply
3 replies to this topic

#1 navdhanjal

navdhanjal

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 23 March 2015 - 10:36 AM

Hi,

Commons was working perfect fine, but then after a server reboot (of our Perforce master server, not the commons server), I can no longer add people to any space. I type in the username, click add, and nothing happens.

Using P4Admin to try and add the people to the group results in the following error (which again was definitely not happening before the master server reboot):

Error in group specification.
'CPU' validation failed: /usr/local/bin/commons_protection_updater.sh: line 58: p4: command not found
/usr/local/bin/commons_protection_updater.sh: line 71: p4: command not found
/usr/local/bin/commons_protection_updater.sh: line 72: p4: command not found

All help appreciated

#2 Tubah

Tubah

    Advanced Member

  • Staff
  • 45 posts

Posted 24 March 2015 - 04:48 PM

The trigger script can't find the p4 executable - probably a path problem as the reboot created a new process and that could have a different PATH.

On your Perforce master server, make sure the 'p4' executable is in the path for trigger scripts   The PATH is likely set  in your p4d startup script.

Or a quick test would be to copy 'p4' (make sure you also chmod +x)  into dirs normally in one's PATH:  /usr/local/bin and /usr/bin.

#3 navdhanjal

navdhanjal

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 25 March 2015 - 11:11 AM

Hi,

P4 is currently in /opt, which is in the current PATH variable on the server. Not sure what you mean by 'path for trigger scripts'

I tried copying the p4 into /usr/local/bin which is where the script itself is located, but it hasn't made a difference.

#4 navdhanjal

navdhanjal

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 26 March 2015 - 01:06 PM

Can anyone help further, as this is basically making Commons unusable in the entire company.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users