Jump to content


Alt F X Shortcut no longer works to exit

p4v shortcut

  • Please log in to reply
6 replies to this topic

#1 joncombe

joncombe

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 21 April 2015 - 12:42 PM

I am in the habit of using Alt+F (to open the File menu) and then X to exit programs, including p4v.

However the version of p4v I have now (2015 February 04) this no longer works. As soon as I press Alt+F it expans the "New" part of the menu and hence the X shortcut for exit doesn't work, as none of the options in this menu have X as a shortcut.

Instead I have to do Alt+F <left arrow> X to exit which is annoying (or Alt+F4). Can this be changed back?

#2 P4Shimada

P4Shimada

    Advanced Member

  • Members
  • PipPipPip
  • 831 posts

Posted 23 April 2015 - 11:43 PM

Hi Jon,

Thank you for reporting this issue.  Can you please give us the full version of your P4V? For example, Help -> System Info -> P4V Version.

Back in the P4V 2007.3 version, the release notes stated

http://www.perforce....er/p4vnotes.txt
    #136474 *
        The key sequence for closing a window on Windows and Unix now uses
        the standard Alt+F4 arrangement; it used to be CTRL+F4.
        (Bug #26573)

#3 joncombe

joncombe

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 24 April 2015 - 10:58 AM

View PostP4Shimada, on 23 April 2015 - 11:43 PM, said:

Hi Jon,

Thank you for reporting this issue.  Can you please give us the full version of your P4V? For example, Help -> System Info -> P4V Version.
Yes, it's P4V version: Perforce Visual Client/NTX64/2014.3/998867

Quote

Back in the P4V 2007.3 version, the release notes stated

http://www.perforce....er/p4vnotes.txt
#136474 *
The key sequence for closing a window on Windows and Unix now uses
the standard Alt+F4 arrangement; it used to be CTRL+F4.
(Bug #26573)

Yes essentially, there are two shortcuts, the one I'm using is for the pull down menus. So Alt+F is supposed to open the file menu (it does), which is what the underline on the F means and X is then meant to exit (as x is underlined in the text exit), but this doesn't work any more.

#4 rhummer

rhummer

    Advanced Member

  • Members
  • PipPipPip
  • 87 posts
  • LocationMadison, WI

Posted 24 April 2015 - 06:06 PM

This may sound odd, but when you right click in P4V does the context menu open cleanly or does it appears to open twice? This visual artifact i've seen in P4V for many years and causes keyboard shortcuts to not work.  

If you are seeing that, support gave me this workaround few years ago:
You can work around it by disabling 'Fade or slide menus into view under Windows System -> Advanced System Settings -> System Properties -> Advanced -> Performance Options -> Visual Effects window.

From what they told me it appears to be a QT issue.
Lead Tools Engineer
Raven Software

#5 joncombe

joncombe

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 28 April 2015 - 03:39 PM

View Postrhummer, on 24 April 2015 - 06:06 PM, said:

This may sound odd, but when you right click in P4V does the context menu open cleanly or does it appears to open twice? This visual artifact i've seen in P4V for many years and causes keyboard shortcuts to not work.  

If you are seeing that, support gave me this workaround few years ago:
You can work around it by disabling 'Fade or slide menus into view under Windows System -> Advanced System Settings -> System Properties -> Advanced -> Performance Options -> Visual Effects window.

From what they told me it appears to be a QT issue.

Yes I do get the menu that appears to open twice. I tried this suggestion and it fixes the problem. I can now use "Alt F X" to exit, which did not work before this change. I think the issue was Alt F caused the New sub-menu to always expand out. Now with this setting that does not happen. Thanks for the suggestion :)

#6 P4Shimada

P4Shimada

    Advanced Member

  • Members
  • PipPipPip
  • 831 posts

Posted 30 April 2015 - 12:08 AM

Jon, thanks for sending us your P4V version and glad the issue resolved. This was a reported known problem caused by either QT or Windows.

rhummer, thanks for chiming in and giving the work-around solution! :-)

#7 JordanStefanelli

JordanStefanelli

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 23 February 2016 - 05:07 PM

Hey Jon -

I came here with the "context menu opening twice" bug, and I live for keyboard shortcuts so altogether this was a good spot.
THANKS for the fix by the way!  

I was going to say "Despite Alt+F now causing this fly-out menu behaviour", yes, you would not combine Alt+F but ALT, F, X to close.
The mnemonic navigation by pressing Alt in Windows is one of the reasons I use it.  For example, to normalize an audio file in Cool Edit (in '98) I'd remember the sun, or "TAN".
alt > Effec_t_s, _A_mplitude, _N_ormalize

It can be used anywhere in Windows.  I.e. shift-right click a file in explorer and press a,a,a and enter.  It should copy the path of the file to your clipboard.


Thanks again for fix!





Also tagged with one or more of these keywords: p4v, shortcut

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users