Jump to content


Unattended install broken in p4vinst64.exe 2014.3.1007540 ??

P4V unattended install setup

  • Please log in to reply
2 replies to this topic

#1 Rob Pitt

Rob Pitt

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 19 May 2015 - 06:55 PM

Hey guys,

I've been using the unattended install feature as documented at
http://answers.perfo...ticles/KB/2456/
to do installs and upgrades for a while.

My command line is:

p4vinst64.exe /v"/qb ADDLOCAL=ALL REBOOT=ReallySuppress"

...and I'm sure this has worked fine in the past.

However with 1007540 it now results in a dialog box:

This setup will perform an upgrade of 'Perforce Visual Components'. Do you want to continue?

... which blocks the installation.

Is this a known issue?
Is there a workaround/fix?

Thanks

#2 Rob Pitt

Rob Pitt

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 19 May 2015 - 07:00 PM

Just confirming that the previous installer 2014.3.998867 can do unattended upgrades of older versions happily.
It definitely looks like this broke in 2014.3.1007540

#3 Mailman Sync

Mailman Sync

    Advanced Member

  • Maillist Aggregator
  • 2495 posts

Posted 30 July 2015 - 12:20 PM

Originally posted to the perforce-user mailing list by: Michael Mirman


Rob -

Try /qn instead of /qb.
I don't remember the details, but we struggled with this, too, and the current script uses either /qn or /qr.
/qn suppresses "more".


--Michael Mirman
508-647-7555
MathWorks, Inc.
3 Apple Hill Dr, Natick, MA 01760

-----Original Message-----
From: perforce-user-bounces@perforce.com [mailto:perforce-user-bounces@perforce.com] On Behalf Of Rob Pitt
Sent: Tuesday, May 19, 2015 3:00 PM
To: perforce-user@perforce.com
Subject: [p4] Unattended install broken in p4vinst64.exe 2014.3.1007540 ??


Posted on behalf of forum user 'Rob Pitt'.

Hey guys,

I've been using the unattended install feature as documented at
http://answers.perfo...ticles/KB/2456/
to do installs and upgrades for a while.

My command line is:


p4vinst64.exe /v"/qb ADDLOCAL=ALL REBOOT=ReallySuppress"  ...and
I'm sure this has worked fine in the past.

However with 1007540 it now results in a dialog box:


This setup will perform an upgrade of 'Perforce Visual Components'. Do
you want to continue?  ... which blocks the installation.

Is this a known issue?
Is there a workaround/fix?

Thanks



--
Please click here to see the post in its original format:
  http://forums.perfor...xe-201431007540
_______________________________________________
perforce-user mailing list  -  perforce-user@perforce.com
http://maillist.perf...o/perforce-user
_______________________________________________
perforce-user mailing list  -  perforce-user@perforce.com
http://maillist.perf...o/perforce-user






Also tagged with one or more of these keywords: P4V, unattended, install, setup

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users