Jump to content


DVCS local DB corruption with network disconnection

dvcs

  • Please log in to reply
No replies to this topic

#1 Kei Son

Kei Son

    Advanced Member

  • Members
  • PipPipPip
  • 46 posts

Posted 21 May 2015 - 05:57 AM

Background story...

I had a local server with small "DepotMap" from shared server for evaluating DVCS feature. It worked perfectly, so I thought, let's expand DepotMap to do more real work! Expanding or shrinking depotmap after cloning has worked well before, so I edited it by "p4 remote origin" and did "p4 fetch".


Processing...

It takes long time. I can wait with patient, but there is a network disconnection when I was out of office.


Problem...

When I hit p4 fetch again, it says:
Can't fetch while files are open. Revert or submit the files first, then run fetch.

I did - p4 revert, got lines that successfully reverting many of the files. Then p4 fetch says same as above. At this time p4 revert notice errors like
Librarian digest xxxx failed.
Error opening librarian file xxxx revision .
RCS checkout  failed!
RCS no such revision !

....

Solving...

I can purge my local server out now. But what is suggested with this scenario?





Also tagged with one or more of these keywords: dvcs

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users