Jump to content


2014.2 upgrade bug with forwarding replicas


  • Please log in to reply
2 replies to this topic

#1 Rakhee

Rakhee

    Member

  • Members
  • PipPip
  • 14 posts

Posted 27 May 2015 - 04:54 AM

Hi,

I just upgraded my server from 2013.2 to 2014.2. I moved to Edge/Commit configuration and had to roll it back to forwarding replica as P4 swarm does not work with Edge configuration. Once I reconfigured the forwarding replica, I am seeing a bug where the clients on forwarding replica do not see opened files.

The replica is up to date as p4 pull comes back with fully synced.

Has anyone else seen this issue?

Thanks
Rakhee

#2 P4Shimada

P4Shimada

    Advanced Member

  • Members
  • PipPipPip
  • 831 posts

Posted 27 May 2015 - 09:25 PM

Hi Rakhee,

Thanks for letting us know which server version you are using. Sorry the configuration is giving you some trouble. To further trouble-shoot, please let us know the following answers:

a] When you mention 'the clients on forwarding replica do not see opened files', which exact command did you run and from which exact server?

b] Are these opened files shelved files?

c] Which server is the Swarm installation pointing to?

d] Have you entered the swarm triggers in the Perforce trigger table?

e] Is it all users on the replica that cannot see opened files or just certain ones? In case there is some type of permissions issue.

f] Do you see any errors in the Swarm or server log?

REFERENCES

- Troubleshooting Perforce Swarm
http://answers.perfo...ticles/KB/3696/

- Perforce configuration for Swarm
http://www.perforce....p.perforce.html

#3 P4Shimada

P4Shimada

    Advanced Member

  • Members
  • PipPipPip
  • 831 posts

Posted 28 May 2015 - 05:38 PM

Rakhee,

I noticed you also had a case with our Tech Support team about the same issue.

I just spoke to one of the developers and they are actively working on this, so that Swarm can operate properly in a Perforce deployment with edge and commit servers. I have added your name and details to the issue request




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users