Jump to content


Command line not working without defining user

command line login ticket

  • Please log in to reply
4 replies to this topic

#1 tomhunks

tomhunks

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 12 June 2015 - 12:37 AM

Hi,

I need some help with stay logged in.
I used to able to run perforce command from command line without specifying my user id. (p4 command [options])

Couple days ago, when I was testing something, I ran LOGOUT command, and now I can't run any command without using global option to specifying my user id.
ei, p4 -u [userid] command [options]
Otherwise, i get following message, "Can't create a new user - over license quota."

We use security level 0 so there is no password I can use.
When I run LOGIN command I get "'login' not necessary, no password set for this user."
What command I need to run to go back to what it used to be? So I can run command without using global option?

Thanks in advance.

#2 P4Shimada

P4Shimada

    Advanced Member

  • Members
  • PipPipPip
  • 831 posts

Posted 12 June 2015 - 12:48 AM

Hello,

Thank you for sending the error message you received. To assist you better with this issue, please answer the following:

a] Which version of the Perforce server are you using? ('Server Version' from "p4 info" command or P4V Help -> System Info)

b] Please check 'Restrictions on Unlicensed Servers' to make sure you are not over the revision limit. See http://answers.perfo...rticles/KB/3159

Let's start here before asking anything else.

#3 tomhunks

tomhunks

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 12 June 2015 - 12:59 AM

Here is the server version.
-Server version: P4D/NTX64/2014.2/962050 (2014/11/13)

Our server has 47 user licenses and it's all being used.
My Perforce UserID is different than my AD UserID, so when I try to run any Perforce command without global option, it gives 'over license quota' error.

Not sure if we have revision limit as we have thousands of files checked in to Perforce already.

thanks!

#4 G Barthelemy

G Barthelemy

    Advanced Member

  • Members
  • PipPipPip
  • 65 posts
  • LocationUnited Kingdom

Posted 12 June 2015 - 10:28 AM

It sounds like the server has not had any security setup (just running "out of the box", maybe ?). So what is probably happening is that accounts are automatically created whenever a new user is accessing the server until the license quota runs out, thus the error message you are getting. That's because the protection table uses a wildcard user rule and the configurable dm.user.noautocreate is not set on the server.

Run "p4 info" without other argument to determine who you are, as far as the Perforce server is concerned. From what you said, this is probably your A/D user account, and that does not correspond to your existing Perforce account, so the server is attempting to create a new account for you but fails because the quota is already full.

To get back to how it used to be, one solution is to set the environment P4USER to the value of your known Perforce account. Why you lost this I believe is unrelated to the "LOGOUT" command (if by that you meant "p4 logout"). If you meant logout from a shell, then it is perfectly possible that your environment was not setup to be persistent and you lost P4USER (or P4CONFIG if you were setup to use a config file). You did not say what operating system you are using, so I am only guessing.

Basically I believe your issue is just a client sided environment issue. "p4 help environment" and "p4 help set" are both worth reading.

#5 tomhunks

tomhunks

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 12 June 2015 - 04:36 PM

My P4USER was set to my AD name for some reason.
I changed the variable using p4 set p4user=[myuserid] and it worked!

Thank you!





Also tagged with one or more of these keywords: command line, login, ticket

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users