Jump to content


Cannot change server


  • Please log in to reply
7 replies to this topic

#1 DanKolle

DanKolle

    Member

  • Members
  • PipPip
  • 12 posts

Posted 25 June 2015 - 07:51 PM

When the default server of p4v cannot be reached, it is impossible to change the server.

Posted Image

I think it would be good to have a button "Change Connection" or "Ignore" so you can enter the user interface to select a different connection.

Dan

#2 P4Shimada

P4Shimada

    Advanced Member

  • Members
  • PipPipPip
  • 831 posts

Posted 25 June 2015 - 08:19 PM

Hi Dan,

Thank you for the feedback. We always welcome suggestions to enhance our products. I have logged an enhancement request on your behalf to add a 'Change Connection' button to the P4V dialog for failed server connection.  I have added your contact details to the report.  Should it be included in a future release you will receive a notification email.

Did you connect via the 'Open Connection' window; and is the 'Show dialog at startup' check-box enabled? Do you have any other 'Connections' setup?

#3 DanKolle

DanKolle

    Member

  • Members
  • PipPip
  • 12 posts

Posted 25 June 2015 - 08:47 PM

I had to restore my server so it got unavailable for a time. Why p4v no uses the defaults I do not know. I never set up a connection to perforce:1666. I now try to get p4v to work again. Reinstalling was without success. I am using Mac OS X P4V 2014.3/1007540.

I disabled the start up connection dialogue in the past as the connection was set up and working.

#4 Matt Janulewicz

Matt Janulewicz

    Advanced Member

  • Members
  • PipPipPip
  • 217 posts
  • LocationSan Francisco, CA

Posted 25 June 2015 - 08:56 PM

perforce:1666 actually is the default.

To get things going you might try editing ~/Library/Preferences/com.perforce.p4v/ApplicationSettings.xml and change the LastConnection setting to something legitimate.
-Matt Janulewicz
Currently unemployed, looking for work in Boise, ID!

#5 DanKolle

DanKolle

    Member

  • Members
  • PipPip
  • 12 posts

Posted 25 June 2015 - 09:23 PM

Thanks that fixed it.

#6 Stardidi

Stardidi

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 05 September 2018 - 08:02 AM

For anyone encountering this in the future:

It seems you can actually choose the 'Ignore' option in this dialog by pressing escape. This will then open the normal 'Open Connection' dialog.

#7 jmucchiello

jmucchiello

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 07 October 2019 - 03:17 PM

DId this feature ever get anywhere? Still need it. It's completely stupid that there's no way into the GUI if the prior connection goes down. Such as during migration to a new server.

#8 simonswartz

simonswartz

    Member

  • Members
  • PipPip
  • 19 posts

Posted 25 March 2020 - 07:13 PM

I'm using P4V 2019.2 and this isn't fixed.

I ran into the problem today. I had to change (0 vs 1) <Int varName="ConnectionstartOption">1</Int> in ApplicationSettings.xml to get the connection dialog to show again.

Since I'm on linux the file is in ~/.p4qt/ApplicationSettings.xml




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users