Jump to content


Upgrading to Git Fusion 2015.2

python git fusion

  • Please log in to reply
1 reply to this topic

#1 charlesa

charlesa

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 26 July 2015 - 06:06 AM

Has anyone else tried upgrading to Git Fusion 2015.2 yet?

We've tried the upgrade (RHEL 6 via rpms) and Fusion is throwing a KeyError exception every time it tries to reference a branch from the branch dictionary object (for pull, clone or really, any action).

What I'm seeing in the logs for a simple single-branch repo is that for these objects:


16030 07-24 13:24:57 p4gf_branch DEBUG branch_dict {'OgE4rkcXR0Cj1arAhKpRvQ==': [OgE4rkcXR0Cj1arAhKpRvQ=]
git-branch-name = master
is_lightweight = False
deleted = False
view =
['//Internal/Dashboard/... ...']
p4map = //Internal/Dashboard/... ...
}
16030 07-24 13:24:57 p4gf_branch DEBUG bsl ['OgE4rkcXR0Cj1arAhKpRvQ==']

Fusion throws an exception with:

  File "/opt/perforce/git-fusion/libexec/p4gf_branch.py", line 875, in _find_first_nondeleted_branch
	branch = branch_dict[name]
KeyError: 'OgE4rkcXR0Cj1arAhKpRvQ=='

The failure for this occurs here (in p4gf_branch.py):

874	 for name in bsl:
875		 branch = branch_dict[name]
876		 if not branch.deleted:
877			 return branch
878	 return None

We've opened a case with support, but so far they haven't been able to help us. I was wondering whether anyone had seen and diagnosed a similar error.

#2 charlesa

charlesa

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 26 July 2015 - 04:48 PM

Initially, it appears that the case of the branch key may be contributing issues here. If I change the auto-generated branch key to lower case, I can do a git pull without raising an exception (given that our master p4d server is case-insensitive and will still find the associated //.git-fusion/objects/repos/*/commits/... files via lower-case branch keys).

Git Fusion uses ConfigParser which, by default treats all keys and option names as lowercase (https://docs.python....ser.optionxform). Fusion is setting the optionxform configuration to str, which should allow for mixed-case strings (and does in our environment on 2015.1), but I wonder whether there's an instance being overlooked.





Also tagged with one or more of these keywords: python, git fusion

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users