Jump to content


BIG PROBLEM - Submits never ends, stuck at 100%, no errors shown in server

p4 p4v submit stuck never end

  • Please log in to reply
2 replies to this topic

#1 Juangea

Juangea

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 02 August 2015 - 11:12 AM

Hi.

I'm having a BIG problem.

When I try to submit a file, in my case they are new fails, so I'm adding files, the submit proccess never ends, when it reaches 100% the window stays open, it says 100% and never ends, I can cancle the action, and then the submit is not done because the files are not in the depot, so nothing is working.

Some ideas please?

Best regards.

Juan Gea.

#2 P4Sam

P4Sam

    Advanced Member

  • Members
  • PipPipPip
  • 484 posts
  • LocationSan Francisco, CA

Posted 02 August 2015 - 03:50 PM

This is definitely one to check with your Perforce administrator and/or technical support; it'll take a little investigation to figure out exactly what's going wrong.

If I were the admin the first two things I would look at are:

1) Do I have any triggers running that might be taking forever to run?
2) Are there any error messages in the log?

As the user trying to submit the change, one thing I might try would be to retry the submit from the command line on the off chance it's a client-side problem.

#3 Juangea

Juangea

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 02 August 2015 - 04:02 PM

I solved it a few minutes after posting here! I've been since yesterday thinking about this and here is the thing:

My Depot is in a network mapped drive to letter Z:, I've been forced to start the perforce server as an administrator proccess instead of service becasue the network read/write permissions.
At the user login I map the drives and after that I start the server, all seemed fine, but it seemed that the server was unable to finish the writing proccess, and there was no error in the server output, finally I thought that the problem was that the Administrator user was not able to see the maped drives by the actual user, so I duplicated the drive mapping commands and I made them to be executed as administrator, and voila! everything solved :)

There was no error anywere, but from a network administrator point of view it was pretty straight forward, the thing is that I'm not just the network administrator in my company, I'm everything, so some times I'm a bit slow reaching solutions hahaha

Thanks for the fast answer!

Cheers!

Juan Gea





Also tagged with one or more of these keywords: p4, p4v, submit, stuck, never, end

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users