Jump to content


Swarm cannot connect to Perforce server during initial configurations

swarm port OVA

  • Please log in to reply
1 reply to this topic

#1 Mihaylov

Mihaylov

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 10 August 2015 - 08:38 AM

Hello,

I'm trying Swarm, using the OVA provided. When I enter the Perforce server port in Virtual machine configuration prompt, the following error message appears:"TCP connect to 1666 failed. 127.0.0.1:1666: Connection refused". The virtual machine and the Perforce server are installed on same machine. The Perforce server is updated to last version (2015.1). The message appears on the VMWare and Oracle virtual machines.

I am not familiar with virtual machine settings.
Any idea how to fix that?

Best regards,
Mihaylov

#2 Ewan Edwards

Ewan Edwards

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 18 August 2015 - 06:25 PM

Hi,

When you see the error "TCP connect to 1666 failed. 127.0.0.1:1666: Connection refused", it means that you have configured the OVA to try connecting to itself, rather than the Perforce service running on the host machine.

The IP address 127.0.0.1 refers to the "loopback" device, which is any computer's own network stack. In this case, the OVA has a network stack that is separate and distinct from the host machine's network stack.

To fix this problem, SSH into the OVA, re-run /opt/perforce/swarm/sbin/configure-swarm.sh, and specify the P4PORT using the IP address of the host machine instead of 127.0.0.1.

I hope that helps!



Also tagged with one or more of these keywords: swarm, port, OVA

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users