Jump to content


p4v - scrambled keyboard input when Xserver does not have XKB extension

p4v xkeyboard

  • Please log in to reply
3 replies to this topic

#1 ckb

ckb

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 25 August 2015 - 12:27 AM

I'm trying to get the latest p4v running on a CentOS VM, displaying back to an Xserver (Xvnc, tightVNCServer) running on a real Ubuntu 14.0.4, and I am having what seem to be font issues.

First, is there a list/guideline somewhere of what packages need to be installed on your Linux servers to have things run correctly?  I think I have them all but there could definitely be something missing.

Anyway, here is what I see at the console while p4v is running:

Qt: XKEYBOARD extension not present on the X server.
Could not initialize OpenGL for RasterGLSurface, reverting to RasterSurface.
Could not initialize OpenGL for RasterGLSurface, reverting to RasterSurface.
Could not initialize OpenGL for RasterGLSurface, reverting to RasterSurface.
Could not initialize OpenGL for RasterGLSurface, reverting to RasterSurface.
Could not initialize OpenGL for RasterGLSurface, reverting to RasterSurface.
Could not initialize OpenGL for RasterGLSurface, reverting to RasterSurface.
Could not initialize OpenGL for RasterGLSurface, reverting to RasterSurface.
Could not initialize OpenGL for RasterGLSurface, reverting to RasterSurface.

And I attached 2 screenshots, one when it first comes up, and then one when I try to open a menu.  You will see the characters change to something unreadable.  Once it goes unreadable it never comes back.  Also you can see the fonts start out incredibly small, would be nice to have them larger.

I was able to install xkeyboard-config on my client, but do not see that package on the available on the ubuntu server.

Thanks for any help.

Attached Thumbnails

  • before.jpg
  • after.jpg


#2 ckb

ckb

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 25 August 2015 - 06:10 PM

So I simplified my setup and stopped running p4v on the VM, and the font problem went away.

I am just running p4v on the fileserver for all 6 of the VMs with 6 different OSes.

I still get the following errors, so I assume they are not related to the rendering problem I saw on the VM:

Qt: XKEYBOARD extension not present on the X server.
Could not initialize OpenGL for RasterGLSurface, reverting to RasterSurface.
ssh: /opt/p4v-2014.3.1007540/lib/openssl/libcrypto.so.1.0.0: no version information available (required by ssh)

The libcrypto one I have seen before, can't remember if I fixed it or punted.  Anyone know offhand?

#3 ckb

ckb

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 25 August 2015 - 06:48 PM

So in case anyone else hits this with libcrypto....

This comes about when you have a P4PORT like us, which is something like "rsh:ssh [options] perforce.foo.com".

When you run ssh from the shell, it looks for and gets the libcrypto in /lib.  When p4v runs it, it gets the libcrypto that ships with p4v and it doesn't like it despite it being the same "version".  So, you could copy over the one that ships with p4v and hope p4v doesn't care.  A better way might be to somehow be able to specify the environment that p4v runs ssh in, so you would have the chance to set an environment variable and possibly affect the library location behavior.

I decided to punt and run 'p4v >& /dev/null' rather than mess with it.

#4 ckb

ckb

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 25 August 2015 - 09:44 PM

So everything was fine until I tried to type into a dialog on p4v.   They keys are all scrambled.

I assume this is because QT is requiring the XKB extension and the Xvnc/TightVNC I am using does not support it.  At least that is what it seems.

Is xmodmap the only option?  Anyone get that to work?  There is no way to tell QT not to use the XKB extension?





Also tagged with one or more of these keywords: p4v, xkeyboard

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users