Jump to content


P4V Integration: 'SSL handshake failed'

Swarm P4V SSL

  • Please log in to reply
4 replies to this topic

#1 JMcIntyre

JMcIntyre

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 16 September 2015 - 05:23 PM

I'm configuring an installation of Swarm version 2015.2/1223788 to connect to P4D version 2015.1/1227227.

Swarm is successfully connected to P4D using SSL. Apache/PHP/Swarm and also using SSL to service web requests. I can log into Swarm, see my commits, make reviews, etc.

I've enabled P4V Swarm integration using the following command: p4 property -a -n P4.Swarm.URL -v https://<my_domain>

When opening P4V I see the following message: Could not connect to Swarm. 'SSL handshake failed'

I expect this could be because I'm using self signed SSL certificates. I won't be getting CA signed certificates any time soon. Can anyone confirm my suspicions to be true? If so, can I work around it in some way?

For reference, here's someone from an earlier thread that's seeing the same message: http://forums.perfor...p4v/#entry18369

Thanks in advance for your help!

#2 P4Shimada

P4Shimada

    Advanced Member

  • Members
  • PipPipPip
  • 831 posts

Posted 17 September 2015 - 06:50 PM

Hi,

Sorry you ran into some issues. Thank you for the other thread reference too.

You will have to either use a certificate signed by a certificate authority (you also have to set HTTP client options in config.php), or allow non-SSL connections on port 80 to get P4V.

It is good that you changed the p4 property, since that is a necessary step.

Are you using HTTPS? Can you connect to HTTPS through a browser? Have you added the configuration to the config.php to enable it?

You will have to allow connections on http to get P4V to connect.  You can configure the virtual host to accept both https connections on port 443, as well as http on port 80.  You should only need two host definitions in the same virtual machine configuration file. One for connections on port 80 and another for connections on port 443.

Note the second configuration in the following link 'Setting up HTTPS for Swarm’:

    http://answers.perfo...ticles/KB/3977/

Hope this has been helpful.

#3 JMcIntyre

JMcIntyre

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 09 October 2015 - 06:06 PM

Thanks for responding. Using a CA generated certificate on the Swarm server solved the problem. Thanks again.

-Jesse

#4 lhota_imangi

lhota_imangi

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 17 February 2016 - 08:00 PM

I am having the same issue.   Can you use self-signed certificates for p4v integration?

#5 BooneJS

BooneJS

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 16 March 2016 - 12:54 AM

I had to revert back to unsecure http to get past this. I'll tinker with Let's Encrypt in the background to see if I can get secure https working.



Also tagged with one or more of these keywords: Swarm, P4V, SSL

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users