Jump to content

Obliterate leaves files behind on disk


  • Please log in to reply
1 reply to this topic

#1 lekjart



  • Members
  • Pip
  • 2 posts

Posted 21 September 2015 - 06:03 PM

I ran obliterate on a few projects which worked fine except that I still some remnants of the Perforce depot files on the hard drive. In some cases these are just empty folder hierarchies, but in other cases there are actual *.gz files containing data.

I was under the impression that obliterate was supposed to really free up the data on disk. Why would it leave some data files behind?

#2 P4Sam


    Advanced Member

  • Members
  • PipPipPip
  • 484 posts
  • LocationSan Francisco, CA

Posted 21 September 2015 - 07:14 PM

If the files in question were copied to another location, the "copies" are actually done by reference on the back end ("lazy copies"), with the source of the copy being the only physical copy of the file on disk.  When you obliterate, the server checks for lazy copy references, and only purges the archive files if nothing is still pointing to them.

Another possibility is that some of these are left over from submits that were interrupted partway through and never resumed.

You can run this command as an admin to see which depot files might be lazy copies of a particular archive path:

	p4 snap -n //... //depot/archive/path/...

Also tagged with one or more of these keywords: obliterate

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users