Jump to content


(P4VS) Visual studio crashing on projects connected to depot

visual studio p4vs perforce visual studio 2013

  • Please log in to reply
1 reply to this topic

#1 dmanniesve

dmanniesve

    Newbie

  • Members
  • Pip
  • 1 posts
  • LocationGlasgow

Posted 22 September 2015 - 12:02 PM

Hi folks,

I'm having an issue where I open up a visual studio solution that has previously been connected to a p4 depot via p4vs and it will immediately seize up and crash after opening to the point where I can't interact with it at all before it crashes. The problem also happens if I try to connect an unconnected solution to the depot.

I've debugged the problem and it appears to be with p4api but I couldn't get much more detail than that.

#2 P4Shimada

P4Shimada

    Advanced Member

  • Members
  • PipPipPip
  • 831 posts

Posted 22 September 2015 - 09:56 PM

Hi Dillan,

Sorry to hear your VS plugin is crashing. To help us better troubleshoot your issue, please let us know the following:
  • What is the version of P4VS you are using? In Visual Studio, go to:

    Tools -> Extension Manager, look for P4VS on the list
  • What is the version of Visual Studio you are using? In Visual Studio go to:

    Help -> About Microsoft Visual Studio

    P4VS is only for Visual Studio versions 2010, 2012 and 2013 and soon 2015
  • What version of Windows are you using?
  • Were there any errors or messages in the P4VS log? For the P4VS log, go to:

    Tools- > Options -> Source Control -> Perforce - Logging

    (This is not the same thing as the Visual Studio Activity log.)
  • Does this happen consistently for all solutios/projects? Is the solution crashing a web project?

Thanks in advance.





Also tagged with one or more of these keywords: visual studio, p4vs, perforce, visual studio 2013

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users