Jump to content


CA SSL Cert/Key Causing Error

SSL P4D ERROR

  • Please log in to reply
No replies to this topic

#1 JMcIntyre

JMcIntyre

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 08 October 2015 - 12:54 AM

I initially configured my Perforce server to run in SSL mode using a self signed certificate/key. It worked correctly, as expected. I'm now trying to replace the self signed certificate/key with a CA signed certificate/key. When I swap in the CA certificate/key, the server will not start and displays the following in the log:

Perforce server error:
Listen 1666 failed.
Either privatekey.txt or certificate.txt files do not exist.
NetSslCredentials::ReadCredentials PEM_read_X509: error:0906D06C:lib(9):func(109):reason(108): Success

The privatekey.txt and certificate.txt do exist and have the correct permissions. I can swap back to my self signed files named the same, in the same directory, with the same permissions and they work fine.

Some additional information that might be helpful:
1. The server is a Linux OS.
2. There is not a public DNS record for this server. It will be accessed by public IP address, or using DNS records in my LAN's DNS, or individual machines' hosts files.
3. The CN (common name) in the self signed cert is different than the one in the CA signed cert. I've tried setting the machine's hostname to the common names in both certs while the CA cert is enabled. No change in behavior.
4. The CA cert is a SAN cert.
5. I also received a root CA chain file with my CA signed certificate and key, but I don't believe p4d has a need for it based on what's I've read in docs or on the internet.

I've done some googling for the error message, but haven't come up with anything very useful. Any idea why I'm getting this error or how to troubleshoot it?

Thanks for your help.

-Jesse





Also tagged with one or more of these keywords: SSL, P4D, ERROR

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users