Jump to content


Not able to connect Swarm to Jira using https

jira swarm

  • Please log in to reply
6 replies to this topic

#1 Wil

Wil

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 09 October 2015 - 07:57 PM

Hello,
Our instance of jira is using a self signed certificate,  the following block has been added to data/config.php


    'http_client_options' => array(
        
'timeout'       => 5,

        
'hosts'     => array(
            
'jira'  => array(
                
'sslcapath'     => '/etc/ssl/certs',
                'sslcert'       => 'jira.pem',
                
'timeout'       => 15,
            
),
        
),


We have made sure that the root certificate and jira certificate are in /etc/ssl/certs and that they can be accessed by any user, however we keep seeing the following in the logs:

2015-10-08T14:24:44-07:00 ERR (3): exception 'ErrorException' with message 'stream_socket_enable_crypto(): SSL operation failed with code 1. OpenSSL Error messages:
error:14090086:SSL routines:func(144):reason(134)' in /opt/perforce/swarm/library/Zend/Http/Client/Adapter/Socket.php:283

Next exception 'Zend\Http\Client\Adapter\Exception\RuntimeException' with message 'Unable to enable crypto on TCP connection pd' in /opt/perforce/swarm/library/Zend/Http/Client/Adapter/Socket.php:310


Any suggestions will be greatly appreciated!!!   Is there another php file that needs to be modified as well? the certificate is SHA1, does that make a difference?


Thanks again!

#2 P4Shimada

P4Shimada

    Advanced Member

  • Members
  • PipPipPip
  • 831 posts

Posted 13 October 2015 - 05:35 PM

Hi Wil,

Thanks for sending the error message. Sorry you are having trouble connecting Jira to Swarm.  What version of Jira and Swarm are you using, by the way?

#3 P4Shimada

P4Shimada

    Advanced Member

  • Members
  • PipPipPip
  • 831 posts

Posted 13 October 2015 - 05:40 PM

Hi Wil,

By the way, yes, you do need a certificate. It makes a difference.

According to the Zend documentation, this error you received typically means that the CA Path has not been set, so SSL cannot verify certificates.

In the Swarm documentation, there's a section on how to configure the HTTP client options to set the "sslcapath" (this would be the local folder that contains the OS's CA bundle, such as /etc/ssl/certs):

See the below link below on how you can tell the Swarm instance where the certificate is located:

http://www.perforce...._client_options

#4 Wil

Wil

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 14 October 2015 - 08:57 PM

Thanks for the response Shimada,
Do we need to add the root certificate to OS's CA bundle?

#5 Wil

Wil

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 14 October 2015 - 11:13 PM

BTW Swarm version is 2015.2  and Jira is v6.3.15

Thanks again!

#6 Wil

Wil

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 21 October 2015 - 04:05 AM

Hi P4Shimada,
Any suggestions?

Thanks!!!

#7 P4Shimada

P4Shimada

    Advanced Member

  • Members
  • PipPipPip
  • 831 posts

Posted 04 November 2015 - 12:55 AM

Did you set your CA path and did you use a certificate? If not, please do so and let us know the results. If yes, and the results did not work, please show your setup is for sslcapath and etc/ssl/certs.



Also tagged with one or more of these keywords: jira, swarm

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users