Jump to content


External P4V unable to connect to p4d with an unreachable p4.swarm.url property

P4V Swarm

  • Please log in to reply
3 replies to this topic

#1 KangThePerforce

KangThePerforce

    Member

  • Members
  • PipPip
  • 24 posts

Posted 27 October 2015 - 06:28 PM

Hi there, we're observing an issue where if a client is unable to dns/reach the swarm host set in p4.swarm.url using P4V 2015.1 they are unable to connect to the P4D server. We're working around this issue for now by advising the external user to revert to P4V 2014.2

Thanks,

Rami

#2 P4Shimada

P4Shimada

    Advanced Member

  • Members
  • PipPipPip
  • 831 posts

Posted 27 October 2015 - 08:04 PM

Hi Rami,

What error(s) are you receiving? For example, do you receive an error of:

  server replied: Not Found'

Does your value for p4.swarm.url have a slash on the end of it? For example:

P4.Swarm.URL = http://SWARMHOST.com/

If there is a slash, remove it and try again.

#3 KangThePerforce

KangThePerforce

    Member

  • Members
  • PipPip
  • 24 posts

Posted 02 November 2015 - 03:29 PM

I tried to reproduce this issue synthetically use multiple approaches and couldn't. I can only assume the external engineer made a mistake and/or misinterpreted the error. If we do ever reproduce this or have more relevant information we'll pass it on.

Thanks,

Rami

#4 P4Shimada

P4Shimada

    Advanced Member

  • Members
  • PipPipPip
  • 831 posts

Posted 11 November 2015 - 09:13 PM

View PostKangThePerforce, on 02 November 2015 - 03:29 PM, said:

I tried to reproduce this issue synthetically use multiple approaches and couldn't. I can only assume the external engineer made a mistake and/or misinterpreted the error. If we do ever reproduce this or have more relevant information we'll pass it on.

Thanks for the update, Rami. Glad the issue went away.





Also tagged with one or more of these keywords: P4V, Swarm

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users