Jump to content


Cannot setup connection with new 2015.3 release


  • Please log in to reply
13 replies to this topic

#1 Yvan POEYMIROU

Yvan POEYMIROU

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 11 November 2015 - 04:12 AM


Hi,


After installation of the release 2015.3, our team get this error in the P4 settings windows

Invalid workspace. The Client path
//MyWorspace/...
maps to this folder
F:\MyWorkFolder\
which is not a parent directory of the projects root:
F:\MyWorkFolder\MySubFolder\Source\

The folders names have been edited for confidentiality, but the message still show the incoherence: The first folder is effectively a parent directory of the project's root, contrary to what the message says.

We tested on multiple clients of multiple persons, and the problem persists.

By looking at the source code, we suspect the following code to be invalid:

public static bool IsDirOrValidSubDirectoryOf(string aSubPath, string aAncestorPath)
{
   if (aAncestorPath.StartsWith(aSubPath.TrimEnd(System.IO.Path.DirectorySeparatorChar, '/'), StringComparison.InvariantCultureIgnoreCase))
   return true;
   return false;


Thanks,


Yvan


#2 calvin-work

calvin-work

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 12 November 2015 - 01:21 AM

Same here, screenshot:

https://www.dropbox....terror.png?dl=0

#3 ryanas

ryanas

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 13 November 2015 - 12:29 PM

I'd just like to confirm that I am also having this issue.

#4 Kenyon

Kenyon

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 15 November 2015 - 03:51 AM

I am also having this problem, and after deleted the new release, tried import older version of p4connect and got "workspace not find' errror! Please fix this!

#5 Yvan POEYMIROU

Yvan POEYMIROU

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 16 November 2015 - 06:21 PM

'Kenyon', I had the same issue.
I am not 100% sure what I have done to fix it, but I think it was by deleting any entry of P4connect in the registry (under HKCU\Software\Unity Technologies\UnityEditor key).

#6 P4Norman

P4Norman

    Advanced Member

  • Staff
  • 81 posts
  • LocationOakland CA, USA

Posted 17 November 2015 - 01:44 AM

Looks like a bug,  we're looking at it.

#7 lpl

lpl

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 17 November 2015 - 02:54 PM

yup, also occuring in here, using Mac with Unity 5.2.2. Any ETA for the fix? =)

#8 dmm

dmm

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 19 November 2015 - 07:44 AM

I am seeing this issue as well (Unity 5.2.2f1) and thought it might be because I am trying to connect via an ssl connection through a project in the Helix Cloud BETA.

I only have P4V installed because P4Connect says it supports ssl connections and I assumed Helix Cloud would be supported, so no need for a P4 local server (localhost).

I have tried connecting via P4Connect and the built in P4 support setup in Unity5 (via Edit/Project Settings/Editor):
  • In the case of using P4Connect 2015.3 I get the error everyone else is reporting in this thread.
  • In the case of the default P4 support, I only get an error message "This version of your client is not supported. Please upgrade to version 2013.2 or higher."
Thanks!

#9 P4Norman

P4Norman

    Advanced Member

  • Staff
  • 81 posts
  • LocationOakland CA, USA

Posted 19 November 2015 - 08:41 PM

This Unfortunately was a stupid bug.

I fixed it and have a new development release you can download from here:

https://swarm.worksh...98.unitypackage

The "official" release for this fix will probably ship in December some time.

Thanks to all of you for reporting this.

-Norman

#10 rtande

rtande

    Member

  • Members
  • PipPip
  • 19 posts
  • LocationBay Area, California

Posted 20 November 2015 - 01:48 AM

Hi Norman,

This development release is working for me. One minor issue was that after the upgrade, I see the "Bad Settings" dialog a number of times when starting Unity. Once I re-enter my password on the Perforce->Settings dialog and save the change these dialogs go away.

I'll post again if I see any issues.

Thanks

- Rajan

#11 Rienhl

Rienhl

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 26 November 2015 - 07:24 PM

Hello Norman,

After using this new release, I was able to setup the connection between P4Connect and my workspace without getting the error that opened this thread.

Test_Fito is my current workspace.
Test is the name of the Depot and the Unity Project.
My workspace mapping is:
//Test/... //Test_Fito/Test/...

Perforce Settings window shows the following, everything's OK!

Posted Image

I hit play on my scene and everything runs smoothly (after showing 4 "Bad Settings" dialog box).
I then proceed to make some operation in the Perforce window, like adding or checking out a prefab and then submitting it.

I hit play once more and at this point everything goes to hell.
This error log starts spamming my console:

Posted Image

Now, P4TestWorkspace_Fito was an OLD workspace I used to test P4Connect some weeks ago. It doesn't exist anymore, I deleted it.
So, it looks like after doing some operation on P4Connect, it reverts the current workspace to a previous one. Somehow, somewhere, there's still a reference set to that old workspace (could it be?).

After this error occurs, I can't play the scene and can't open the Perforce Settings window. I have to force close Unity.

As soon as I reopen Unity I get his:

Posted Image

So I check my Perforce Settings, which are all correct! Perforce integration shows as ACTIVE and ENABLED.
At this point I can't use P4Connect and I can't play the scene without having to force close Unity again.

Is anybody else experiencing this?
Is there any solution?
Is it just me and some wrong setting?

Thanks in advance for any help! I really enjoyed using P4Connect with Unity 4. All my team did. (Specially artists).
Now that we had to upgrade to Unity 5 we are struggling with this asset and each time it gets updated we hope to finally be able to use it.
I really want it to be this time.

Cheers!

-Fito

#12 redthrawn

redthrawn

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 07 December 2015 - 09:55 PM

@Rienhl I am having the same problem. I got rid of the 'bad settings' problem by using the latest build of the package but I can't get past the exception.

#13 rtande

rtande

    Member

  • Members
  • PipPip
  • 19 posts
  • LocationBay Area, California

Posted 09 January 2016 - 01:18 AM

FYI the official release with the fix that P4Norman mentioned on the 19th of Nov is 2015.3.1311537 released Dec 10th 2015 to the Unity Asset Store

#14 PedroCori

PedroCori

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 13 January 2016 - 11:08 PM

View Postrtande, on 09 January 2016 - 01:18 AM, said:

FYI the official release with the fix that P4Norman mentioned on the 19th of Nov is 2015.3.1311537 released Dec 10th 2015 to the Unity Asset Store

I installed the latest version and the one suggested by P4Norman, but I still get the error. "Bad settings, flease Fix"

Invalid Workspace. The client path:

//my_workspace/...

maps to this folder:

E:\foo\bar

which is not a parent directory of the project's root:

E:\foo\bar\project_name\






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users