Jump to content


Windows Explorer plug-in says "server unavailable"

Windows Explorer plug-in P4EXP

  • Please log in to reply
1 reply to this topic

#1 Orthoducks

Orthoducks

    Member

  • Members
  • PipPip
  • 12 posts

Posted 14 December 2015 - 05:53 PM

The transcript for the Perforce Plug-In for Windows Explorer video says that "If you installed P4V with the default settings, P4EXP is already available."

P4V is installed, and Explorer's context menu has a "Perforce" entry. When I click it, though, it opens a sub-menu whose first entry is disabled text that says, "The server is currently unavailable."

It's not true. P4V finds the server completely available!

I thought P4V and the plug-in might not be able to access the server at the same time, so I quit P4V, opened a new instance of Explorer, and tried again. Same result.

I tried the Perforce->Connections command and got an error message which suggested that to use the plug-in I might have to start a Windows Explorer instance from P4V, so I tried that. Again, same result.

The system is Windows 7 Enterprise. P4V says its revision number is "NTX64/2014.1/888424."

What is wrong?

#2 P4Shimada

P4Shimada

    Advanced Member

  • Members
  • PipPipPip
  • 831 posts

Posted 17 December 2015 - 08:51 PM

Hi,

Sorry to hear you are having a hassle with P4Exp. Thank you for sending your P4V version. Which version of P4Exp do you have installed? You can follow these steps to determine which P4EXP version is installed on your system:

   a. In Windows Explorer, navigate to a folder that is managed by Perforce
   b. Right-click on a file
   c. Select Perforce > Connection Information
   d. In the Connection Information dialog, look for 'Client version'

View PostOrthoducks, on 14 December 2015 - 05:53 PM, said:

The transcript for the Perforce Plug-In for Windows Explorer video says that "If you installed P4V with the default settings, P4EXP is already available."

Heads up! As of March 2015, P4EXP 2012.2 is packaged in its own installer, p4expinst.exe or p4expinst64.exe - see the P4EXP release notes:

https://www.perforce.../p4expnotes.txt

Also, see the P4V release notes also under 'Installation':

3. As of version 2014.3, P4EXP is removed from the P4V installer.
   The first time you upgrade P4V and its components from 2014.2 or
   earlier, P4EXP will be uninstalled. See the P4EXP release notes
   for separate installation instructions.

View PostOrthoducks, on 14 December 2015 - 05:53 PM, said:

P4V is installed, and Explorer's context menu has a "Perforce" entry. When I click it, though, it opens a sub-menu whose first entry is disabled text that says, "The server is currently unavailable."

The message "The server is currently unavailable." may be due to you needing to have the P4PORT, P4CLIENT and P4USER values set for P4EXP. Make sure that your P4V connection settings match with your P4EXP connection settings.  

P4EXP takes its configuration parameters from, in order of precedence, the following:
  • The configuration file, if any

  • Environment settings (the registry)

  • System defaults (for example, P4CLIENT defaults to the system's hostname)
Please send the output of the "p4 set" command from your client PC.

REFERENCE

- Using Multiple Workspaces with P4EXP
http://answers.perfo...rticles/KB/2768





Also tagged with one or more of these keywords: Windows Explorer plug-in, P4EXP

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users