Jump to content


Setting up new perforce server

setup server p4d

  • Please log in to reply
3 replies to this topic

#1 SalJ

SalJ

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 05 July 2016 - 11:20 AM

A while ago I successfully set up a perforce server and client. I built a new PC and need to setup a perforce server on it. The issue is the process seems to have changed since last time and now I have no idea how to do it.

When I download the server it comes as a zip file with 4 different exe files. I think the one I need is p4d but when I click it brings up a console that says "Perforce Server Starting..." and it never says that its done starting it, I can't type anything into the console, nothing else pops up, and there doesn't seem to be a perforce service when I look for it under services.

I checked the tutorial videos but those don't help since they use completely different files. I'm completely lost. Any help you can provide would be greatly appreciated.

#2 Domenic

Domenic

    Advanced Member

  • Members
  • PipPipPip
  • 105 posts

Posted 06 July 2016 - 06:40 PM

Which OS are you running? If you're on Windows I'd recommend downloading the installer from https://www.perforce...downloads/helix as it will handle the service setup for you. I'd also recommend https://www.perforce...r.install.html.

#3 SalJ

SalJ

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 07 July 2016 - 02:39 AM

The second link 404s and the first one just takes me to the download page where I downloaded the zip files. Since I didn't get a reply I downloaded the old 2015 version which has an installer and how have perforce up and running. The issue is I can't get this new version to work.

#4 Domenic

Domenic

    Advanced Member

  • Members
  • PipPipPip
  • 105 posts

Posted 07 July 2016 - 05:46 PM

Ah, it looks like the hyperlink had a period appended at the end when I finished the sentence. https://www.perforce...er.install.html should work.

For the first link, yes, it is to the download page. Isn't there a "Windows Installer (x86)" (or (x64)) option for the 2016.1/1405859 release you can choose to download for the Helix Versioning Engine? That should have set everything up for you using the latest version so you wouldn't need to manually run p4d.

At this point, since you're on an old 2015 release you should be able to use the info from https://www.perforce....html#DB5-83649 (specifically, under "upgrading p4d") to get your server up to the latest version. Assuming you're able to download the 2016.1 installer that is.. if you're not, you can still stop your server, copy in the latest p4d executable (to C:\Program Files\Perforce\Server? check your service settings to confirm), run 'p4d -r <server-root> -J <journal-file> -xu', then restart the service.





Also tagged with one or more of these keywords: setup, server, p4d

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users