Jump to content


P4V using custom diff tool arguments not working correctly when using whitespaces

diff tool arguments custom p4v

  • Please log in to reply
2 replies to this topic

#1 xEric_xd

xEric_xd

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 03 November 2016 - 12:30 PM

I've created a custom diff tool that I now want to use in perforce.

In edit->preferences->diff, I have changed the default diff application to my own one.
For the arguments, I have:
%1 %2 "C:/Program Files/path_to_file"

The arguments i get inside my custom tool are:
file represented by %1
file represented by %2
"C:/Program
Files/path_to_file"

The file names are passed perfectly fine.

Why is it cutting of the path? It's surrounded by quotation marks so surely it should be passed as a single argument?
When running the custom diff tool from visual studio and specifying the above mentioned arguments manually it works fine, so it seems that perforce is cutting the argument at the white space.

#2 Morghar

Morghar

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 27 October 2017 - 07:51 PM

Hi,

I'm having the same issue and it is quite blocking. Do you have any way of fixing this? It seems that passing an argument containing a space will split it in 2 like you say. I tried adding quotes etc, and it still doesn't work.

#3 P4Reg

P4Reg

    Advanced Member

  • Staff Moderators
  • 98 posts

Posted 06 November 2017 - 04:13 PM

Perhaps try the DOS short path name so you don't have a space in the path:

C:\PROGRA~1\path_to_file

(see http://stackoverflow...of-windows-path)





Also tagged with one or more of these keywords: diff, tool, arguments, custom, p4v

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users