Jump to content


Issues setting up P4Connect on Unity for the first time


  • Please log in to reply
1 reply to this topic

#1 Draice

Draice

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 18 December 2016 - 02:43 PM

Hello,

I'm having issues trying to get P4Connect working inside Unity properly. From the following screenshot, you can see the Addon is connected to the P4 server, in the P4V window the sprite assets have been added, but in Unity's asset window below the P4V client, there are no status overlays over the sprites. I have the "Display Status Icons" selected in the Perforce Settings.

When I right-click > Perforce on one of the assets, "Add to Depot" is still a valid option, while "Checkout" is not, despite these assets already existing on the Perforce server as shown in the preceding desktop.

My project is just a skeleton project, newly setup with several addons imported into it. No work has been started on it, and the assets shown above are the Free ones in the Unity Standard Assets pack.

If there are any tips you can provide that will help me getting Perforce working in Unity, I;d be most appreciative. I am using Unity 5.4.3f1 Personal.

Thanks,
Draice

Attached Files



#2 P4Norman

P4Norman

    Advanced Member

  • Staff
  • 81 posts
  • LocationOakland CA, USA

Posted 19 January 2017 - 08:04 PM

Hi Draice,

I think you ran into a problem P4Connect had with Unity 5.4+

Please download and try the 2017.1 release from the ftp site here:  ftp://ftp.perforce.com/perforce/r17.1/bin.multiarch/p4Connect.unitypackage




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users