Jump to content


Unable to load resource file - error.

error bug resource file

  • Please log in to reply
7 replies to this topic

#1 ty567

ty567

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 12 April 2017 - 09:07 AM

Hello.

I had some trouble with P4A, so yesterday I updated everything to the newest version.
Now, when I try to open P4A, P4V and P4Merge I get the following error message:

"Error initializing Helix Visual Client.
Unable to load resource file."

P4A opens after the error, but icons don't display, P4Merge seems to open OK, and P4V doesn't open at all (and that's my biggest problem).
I tried doing the repair installation, but it didn't help.

Is there a way of fixing it without having to reinstall the whole thing?

Windows 8.1
P4A version: 2017.1/1491634

Thanks for help.

#2 aCravatta

aCravatta

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 12 April 2017 - 05:08 PM

Just updated my P4V/Admin/Merge/etc client, and now I am getting the same problem where I didn't previous to the update.

Windows 7
Current revision: Rev. P4Admin/NTX64/2017.1/1491634

Anyone have any idea what's causing this?

#3 aCravatta

aCravatta

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 18 April 2017 - 01:17 PM

Is there no one from Perforce on these forums? My attempts to find this problem through Google have yielded only one case from 2012, which ended up being an entirely different issue. If I could at least know what the program is looking for so I can try to fix it myself, that would be better than silence...

#4 Robert Cowham

Robert Cowham

    Advanced Member

  • PCP
  • 270 posts
  • LocationLondon, UK

Posted 18 April 2017 - 01:35 PM

I have seen this be fixed by running uninstall and reinstall.

Might be worth running procmon (https://technet.micr...essmonitor.aspx) to see what P4V is looking for and if any errors. You can filter by p4v.exe and status.
Co-Author of "Learning Perforce SCM", PACKT Publishing, 25 September 2013, ISBN 9781849687645

"It's wonderful to see a new book about Perforce, especially one written by Robert Cowham and Neal Firth. No one can teach Perforce better than these seasoned subject matter experts"
  • Laura Wingerd, author of Practical Perforce, former VP of Product Technology at Perforce

#5 aCravatta

aCravatta

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 20 April 2017 - 02:49 PM

I ran Procmon and I notice p4v is trying to 'create file' in the P4 base folder a lot with 'NAME NOT FOUND' as the result (usually because there is no file in the P4 directory with that name, but it has the same result even if there is), then does the same in the Windows\System32 directory. It does this same process a good 12ish times in a row with the 'wdmaud.drv' which exists in System32, but not in \P4. (see attached screenshot)

I'm not particularly savvy to thread-based investigations (I've only done it a few times in the past), so is there anyone that can make sense of all this? I'd like to get to the root of this if possible. Since there is no 'technical support/discussion' area, might as well do it here!

Attached Thumbnails

  • P4V_Procmon.png


#6 p4rfong

p4rfong

    Advanced Member

  • Staff Moderators
  • 343 posts

Posted 20 April 2017 - 04:33 PM

Try downloading the file named "MicrosoftProgram_Install_and Uninstall.meta.diagcab" in the article "Fix problems that block programs from being installed or removed".

https://support.micr...lled-or-removed

See if you can either complete the install, or uninstall P4V.

#7 tishun

tishun

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 16 May 2017 - 03:06 PM

Same problem here. Simple reinstall did not do the job.

I suppose it's a lock / permissions issue.

Run with administrator privilege (right click -> "Run as Administrator") both installer and P4V.

Did the job for me.

#8 p4_throwaway2

p4_throwaway2

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 01 June 2017 - 05:22 PM

Late to the party, but ran into this and was able to fix my install by copying

C:\Program Files\Perforce\P4VResources\images.rcc

to

C:\Program Files (x86)\Perforce\P4VResources\images.rcc

I'm guessing this is a 64 bit client install over an existing x86/win32/32 bit installation bug, which installs the 64 bit client into the existing install location under 'Program Files (x86)', but puts images.rcc into 'Program Files' just for laughs.





Also tagged with one or more of these keywords: error, bug, resource file

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users