Jump to content


Enable unicode on P4 server

P4 server configuration unicode

  • Please log in to reply
1 reply to this topic

#1 mszhangjiao

mszhangjiao

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 12 April 2017 - 01:08 PM

Hello,

I have downloaded and installed the latest version of p4d and p4v today, and I tried to setup a server and client on my own machine.

When I ran the command: p4 typemap, I got an error: "Unicode clients require a unicode enabled server." In order to fix this issue, I tried to enable unicode on the server by following section "Setting up a server for Unicode" in this document:

https://www.perforce...onfiguring.html

After converting the server to Unicode, with command line:

p4d -xi -r E:\projects

I saw a lot of ad.xxx files were generated in E:\projects.

When I restarted the server with command:

p4d -r E:\projects -p 1666

I was able to run command p4 typemap without the unicode error.

But the problem is if I start the Perforce Service, perforce server no longer supports unicode. I will get the error "Unicode clients require a unicode enabled server" again. It's said that enabling unicode is ONE-Way change, we can't change it back to non-unicode. How is this happening? Change with p4d will not affect the Perforce Service started by p4s? How can I make this change to the Perforce Service (p4s) as well?

Many thanks,
Jiao

#2 Sambwise

Sambwise

    Advanced Member

  • Members
  • PipPipPip
  • 1084 posts

Posted 12 April 2017 - 06:33 PM

Is E:\projects the P4ROOT directory that your Perforce service uses?

What does "p4 set -S Perforce P4ROOT" show you?





Also tagged with one or more of these keywords: P4 server, configuration, unicode

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users