Jump to content


Swarm Notifications - not getting email notification after installing new instance

swarm

  • Please log in to reply
2 replies to this topic

#1 mcru

mcru

    Advanced Member

  • Members
  • PipPipPip
  • 67 posts

Posted 20 July 2017 - 01:07 PM

I do have an open case with support on this, but was wondering if anyone else has seen this same issue.

In the latest version of Swarm, we're not not getting any email notifications. We had previously installed an earlier version of Swarm when evaluating Perforce, and were receiving email notifications without issue. Now, on the latest version of swarm, with otherwise identical configuration (though, a different p4 server), we're not getting any email notifications. Working with support to explicitly enable notifications via configuration options that should default to on, and then adding review paths to user specs, we were able to get 'old' style perforce review messages, but nothing from swarm itself. The logs do not show that it is creating emails, and sendmail works (I've tested by writing a php script to send email, and sending email from the cmd line).

Has anybody seen this in swarm 2017.1, or any earlier versions? Have any suggestions?

#2 P4Martin

P4Martin

    Member

  • Staff
  • 21 posts
  • LocationUK

Posted 21 July 2017 - 06:59 AM

Hi there,

There was a fairly significant overhaul of the notifications system in 17.1 to allow for more fine-grained user configurable notification settings (see your user profile page > Settings).

Really sorry that this has caused problems, we will try to do better next time, and I'm sure Support will get you going soon!


Martin.

#3 mcru

mcru

    Advanced Member

  • Members
  • PipPipPip
  • 67 posts

Posted 27 July 2017 - 02:09 PM

Thanks Martin. It ended up being a combination of new settings and restricted changelists. For anybody who comes across this in the future - make sure you have 'email_restricted_changes = true' in your config.



Also tagged with one or more of these keywords: swarm

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users