Jump to content


Please Help: BUG: Can't execute P4V because it doesn't find dll. files

p4v bug dll win10 system error help

  • Please log in to reply
4 replies to this topic

#1 RobertFIN

RobertFIN

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 03 September 2017 - 04:53 PM

I'm running win10 64bit, and I need p4v to connect to my friend's server as we are going to make a game Project. However, always when I install the app, let it through firewall and try to open p4v for the first time, it says that program couldn't be executed due to system error because it doesn't find these files:

LIBEAY32.dll
SSLEAY32.dll
Qt5OpenGLP.dll
Qt5CoreP4.dll

The most annoying part of it that those files actually are in the perforce folder, even I can find them easily, but the program doesn't.

I've tried to reinstall my GPU driver and I've tried to reinstall the whole operating system and deleting everything on my pc including all settings and it still doesn't work, even though I only downloaded p4v straight after reinstalling win10 os... I am really sad because this is threatening the whole game Project... All I can say is please help and thanks in advance. Ask anything if you want to know more details.

#2 P4Jen

P4Jen

    Advanced Member

  • Staff Moderators
  • 143 posts

Posted 07 September 2017 - 11:53 AM

Hi Robert,

I suggest contacting 'support@perforce.com', so they can help investigate this further.

Are you downloading P4V from our website?

If not I suggest you give this a try, as if you are getting it from another source there may be issues with the binary.

I hope this helps,
Jen.


#3 P4JoelK

P4JoelK

    Member

  • Staff Moderators
  • 15 posts

Posted 07 September 2017 - 08:17 PM

Hi Robert,

Support won't respond unless you are a licensed user with support.  If you are, please include your "p4 info" from the server.

All those libraries should be included when you install P4V.

I would recommend completely uninstalling P4V, and then installing the latest.

   ftp://ftp.perforce.com/perforce/r17.2/bin.ntx64/p4vinst64.exe

If that does not fix it, then have a look at your PATH.  Maybe one or more components is being found elsewhere.  Put "C:\Program Files\Perforce" at the beginning of the PATH.

Regards,

Joel

#4 RobertFIN

RobertFIN

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 07 September 2017 - 08:51 PM

Hey,

The problem solved itself... I feel like an idiot, but the problem was that I moved the p4v app out from the folder, so that's why it didn't find the files it needed. I should've made a shortcut.... well, sorry for taking you time.

Thread closed, a moderator can delete this, if that helps.

#5 p4rfong

p4rfong

    Advanced Member

  • Staff Moderators
  • 342 posts

Posted 03 October 2017 - 02:20 AM

This looks like useful information to others who may encounter the same error, so we will keep this posted.





Also tagged with one or more of these keywords: p4v, bug, dll, win10, system, error, help

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users