Jump to content


P4python will not install via pip on Linux

python p4python

  • Please log in to reply
2 replies to this topic

#1 mcru

mcru

    Advanced Member

  • Members
  • PipPipPip
  • 67 posts

Posted 17 November 2017 - 11:49 PM

When I try to install p4python via pip on linux, pip will download the .tar.gz but then hangs when it should be unpacking/building. Any ideas?

Example below. Note that the first time I tried pip install it downloaded the .tar.gz, subsequent runs try to use the cached version.

$ pip install p4python
Collecting p4python
	Using cached pypython-2017.1.1526044.tar.gz


It then just hangs like this.

#2 sammex

sammex

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 27 August 2018 - 03:17 PM

I had the same issue and my solution (Ubuntu) was to just use the Perforce package repo to install it with:
apt-get install perforce-p4python3


#3 P4Jen

P4Jen

    Advanced Member

  • Staff Moderators
  • 147 posts

Posted 28 August 2018 - 03:30 PM

Hi,

It would be useful to know which version of PIP you are using, which version/flavour of Linux this is, and how you installed PIP.

I was able to successfully install P4Python on Ubuntu Trusty using PIP, that was installed using 'easy_install'.

When I tried using the package 'python-pip', available in the apt repos, I was unable to install it.

Note I did not see exactly the same behaviour as you, as my install got to the compilation stage before falling over with an error.

The version of pip provided by 'python-pip' was older than the version provided with 'easy_install'.






Also tagged with one or more of these keywords: python, p4python

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users