Jump to content


Connection settings not saved per solution


  • Please log in to reply
6 replies to this topic

#1 mlussier

mlussier

    Member

  • Members
  • PipPip
  • 19 posts

Posted 31 May 2018 - 07:00 PM

On version 2018.2.166.5359 of the P4VS plugin.

In the "Perforce - Connections" settings I have the "Connect to the server using solution-specific settings" option enabled.  Previously I would have to set the connection settings once per solution, and it would auto connect on subsequent loads.  Now, I am prompted with the Connection dialog on each load.

How do I get the plugin to remember my connection settings with out having to select them each time I open the solution?

#2 p4bill

p4bill

    Advanced Member

  • Members
  • PipPipPip
  • 160 posts

Posted 31 May 2018 - 07:27 PM

P4VS has been changed to load asynchronously. This is in anticipation of a VS 2017 update which will no longer allow synchronous autoloading of packages. In VS 2015 and 2017 solutions will load before the plugin. Are you using either of those versions of Visual Studio? This sounds like a bug related to that.

A quick test here with that setting appears to connected automatically with the solution-specific settings when I:
1. Open Visual Studio 2017
2. Open solution from within Visual Studio

but I do see the Connection dialog when I open a solution from outside of Visual Studio (e.g. double-click on a .sln file in explorer).

Is that how you are opening the .sln?

#3 mlussier

mlussier

    Member

  • Members
  • PipPip
  • 19 posts

Posted 31 May 2018 - 07:48 PM

I am on VS 2017 version 15.7.1.

I am double clicking on the .sln to open.  When opening the .sln from inside VS, I am not prompted by the Connection dialog.

Is there an ETA on when the VS update will be released?  Will this behavior go away with that update?

#4 p4bill

p4bill

    Advanced Member

  • Members
  • PipPipPip
  • 160 posts

Posted 31 May 2018 - 08:12 PM

The VS update is supposed to be 15.8, but I don't know when that is scheduled. I would expect that it would be within an couple of months based on their recent cadence.

Unfortunately, this will not go away with that update. This is a side affect of changes to work with that update. I'll log a bug here and we'll investigate.

A potential workaround in the meantime may be to "Connect to the server using my Perforce environment settings". That seems to be working in my quick tests here. Though, if you are connecting with different workspaces for different solutions, you'd probably need to use a P4CONFIG setting.

#5 mlussier

mlussier

    Member

  • Members
  • PipPip
  • 19 posts

Posted 31 May 2018 - 08:25 PM

Unfortunately we are using Streams so I have lots of solutions using different workspaces.  It would be really nice if there was a solution for this issue but from your description I understand if it is not feasible.

#6 p4bill

p4bill

    Advanced Member

  • Members
  • PipPipPip
  • 160 posts

Posted 31 May 2018 - 09:26 PM

P4CONFIG would be the way to go, but I understand if that is too much overhead. Hopefully we'll release a fix before too long.

The only other thing I can think of would be to rollback to 2018.1 (and uncheck Automatically update this extension in the extension manager)

extension_manager.JPG

You can get 2018.1 here: ftp://ftp.perforce.com/perforce/r18.1/bin.ntx86/

Apologies for the inconvenience and thanks for reporting this.

#7 p4bill

p4bill

    Advanced Member

  • Members
  • PipPipPip
  • 160 posts

Posted 26 July 2018 - 02:56 PM

This is fixed in the latest version, 2018.3.168.2696 just released a couple of days ago.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users