Jump to content


Views stopped working, getting error "Cannot find P4V.exe"

P4VS

  • Please log in to reply
2 replies to this topic

#1 Morfi

Morfi

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 27 August 2018 - 10:02 AM

Hello

I have an issue with the plugin for Visual Studio 2015.
Recently the "Views" section when you right click on a open file in VS are not opening. When selecting either "View in P4V", "Time-lapse View" or any other produce dialogue window from P4VS with error "Cannot find P4V.exe".

I tried to reinstall the plugin several times, but it does not work. It's strange because Diff and all other functionalities of P4VS work, but all the Views are throwing that error.

Anyone might have an idea how to fix this? I would really love to have those functionalities back :(

#2 p4bill

p4bill

    Advanced Member

  • Members
  • PipPipPip
  • 175 posts

Posted 27 August 2018 - 09:13 PM

Hello,

I just tried it with version 2018.3.168.2696 and was able to launch P4V and Time-lapse View.

My initial guess is that the location of P4V is saved in the LocalSettings, but that location is not correct.

You can find that settings file here:
C:\Users\<user>\AppData\Roaming\Perforce\P4VS\LocalSettings.ini

The line that specifies the P4V location is:
<P4V_path type="string">C:\Program Files\Perforce\P4V.exe</P4V_path>

Can you check if that is set, and if it matches the actual location of the P4V application?

This is only needed for P4V based views, diff and merge use P4Merge which is set in that same file with P4Merge_path, but can also be changed in Tools -> Options -> Source Control -> Helix Core - Diff/Merge.

#3 Morfi

Morfi

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 28 August 2018 - 08:39 AM

Hello,

Yes i've checked the LocalSettings file and all seems ok. At first i changed the path cause there was just difference with lowercase only letters, but it does not seem to affect it anyhow.

My fix to this problem was to update my Helix client. I was using 2017.2 version of Perforce visual client, and after updating to 2018.2 it started working! Strange though as it WAS working a month ago and just stopped suddenly.

Either way thanks for help!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users