Jump to content


chmod: server.locks operation not permitted


  • Please log in to reply
2 replies to this topic

#1 prabhu

prabhu

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 03 November 2018 - 06:11 PM

Hello,
I have a home perforce server which has started throwing error for creating any new workspace.

Details:
1. Server version: P4D/LINUX26ARMEL/2015.2/1500215 (2017/03/27)
2. Platform: Raspberry Pi
3. P4ROOT - mapped to NFS drive

The server was fully functional with two different client machines and workspaces. However, out of the blue I am now getting error in using these workspaces (chmod: server.locks operation not permitted). Even trying to create a new workspace fails with the same error.

I have verified that the disk access and read / write permissions are good (i.e. I can create directory and files on the p4root mount point).

I tried disabling server locks, but the problem exists.

p4 lockstat -C command also gives me the same error (chmod: server.locks/meta/db: Operation not permitted)

Any suggestions on how to debug / fix this issue?

-prabhu

#2 P4Jen

P4Jen

    Advanced Member

  • Staff Moderators
  • 137 posts

Posted 05 November 2018 - 03:25 PM

Hi prabhu,

If the 'server.locks' directory still exists, please run:
  ls -alh
against it and check the system account running the Perforce Server has permission to create files within it.

Here is an example from my system:
bash-3.2$ ls -alh server.locks
total 0
drwx------   7 jbottom  staff   224B  3 Jul 15:37 .
drwx------  96 jbottom  staff   3.0K  5 Nov 15:22 ..
drwx------   5 jbottom  staff   160B  8 Oct 16:15 change
drwx------   5 jbottom  staff   160B 24 Oct 16:20 clientEntity
drwx------   4 jbottom  staff   128B 22 Aug 12:15 clients
drwx------   4 jbottom  staff   128B  3 Jul 15:02 meta
drwx------   3 jbottom  staff    96B  3 Jul 15:37 streams
  <Snip>

Note 'jbottom' is the system account running the server.

As the 'server.locks' directory does not need to be backed up, you could also try removing it,
re-enabling server locks, and seeing if it is re-created next time you try working with your clients.

Hope this helps,
Jen.


#3 prabhu

prabhu

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 06 November 2018 - 06:54 PM

Thanks Jen, this has resolved the issue!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users