Jump to content


Ignored sub folder still set "Read-only"


  • Please log in to reply
2 replies to this topic

#1 tgienger

tgienger

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 07 November 2018 - 05:59 PM

I have a project that relies on generating files into a sub folder. I need access to the parent folder for stuff I create, but the sub folder needs to be able to delete and re-create folders and files at will.
mainline -> shema -> generated_files

I need generated files to remain unlocked so it can be erased and written at any time.

As mentioned I ignored the 'generated_files' folder and it works, p4 ignores recognizes that it is ignored and none of the files are added. However the problem occurs when the program is ran and the first set of 'generated_files' are created each file inside is set to "Read-only". The second time I run the program it fails an requires that I either delete "generated_files" or unchecked "Read-only" under folder properties.

#2 P4Jen

P4Jen

    Advanced Member

  • Staff Moderators
  • 137 posts

Posted 08 November 2018 - 05:40 PM

Hi Tgienger,

Setting 'allwrite' in the Helix Client specification may help.

When this option is set, files in the workspace are writable by default.

Hope this helps,
Jen.


#3 Sambwise

Sambwise

    Advanced Member

  • Members
  • PipPipPip
  • 640 posts

Posted 08 November 2018 - 08:37 PM

If the "generated_files" folder is ignored, it's not getting added to Perforce -- so how is it getting set to read-only?

Setting "allwrite" on the client spec won't affect these files if they're being generated locally rather than being synced from the Perforce server.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users