Jump to content


New Perforce Ubuntu server won't start

Listen :1666 failed TCP listen on :1666 failed. bind: 0.0.0.0:1666: Address

  • Please log in to reply
3 replies to this topic

#1 BlueTigerAnimations

BlueTigerAnimations

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 05 February 2019 - 03:03 PM

Hi Everyone :)
This is my first time posting here, using perforce, and using Linux so please be gentle :D

I've been trying to set up a P4D server on my Ubuntu station for a while now so me and my team can try using PF instead of GIT, but even after Following the instalation step by step, and and searching on google for days, I keep getting this error whenever I use "p4d" to start the server:


Perforce server error:
    Listen :1666 failed.
    TCP listen on :1666 failed.
    bind: 0.0.0.0:1666: Address already in use



Does anyone know how to fix this? atm nobody can connect :/ I've tried setting different ports, and IPs, but nothing works. I'm very sure there isn't actually another process running on that adress and I even tried setting other adresses.

Here is my p4 info:

User name: super
Client name: server-game
Client host: server-game
Client unknown.
Current directory: /home/dave
Peer address: 127.0.0.1:59306
Client address: 127.0.0.1
Server address: localhost:1666
Server root: /opt/perforce/servers/master/root
Server date: 2019/02/05 15:56:48 +0100 CET
Server uptime: 15:50:53
Server version: P4D/LINUX26X86_64/2018.2/1751184 (2019/01/21)
ServerID: master
Server services: commit-server
Server license: none
Case Handling: sensitive

Thanks in advance! :)


#2 Sambwise

Sambwise

    Advanced Member

  • Members
  • PipPipPip
  • 713 posts

Posted 05 February 2019 - 04:28 PM

Sounds like you already have a p4d running on that port?  Both the error message and the "p4 info" response from that server support that.  :)

If nobody else can connect to it, maybe it's only listening on localhost?  Try shutting it down with "p4 admin stop" and then try launching p4d with a port of "1666" like you were trying to do in the first part of your post.

If it's still not reachable by other people, make sure there isn't a firewall in front of it, etc.

#3 P4Jen

P4Jen

    Advanced Member

  • Staff Moderators
  • 141 posts

Posted 05 February 2019 - 04:36 PM

Hi,
The error you are seeing indicates that the address and port you are trying to use to start the server are being used by something eels.

The fact that you are able to run 'p4 info' indicates that you already have an instance of P4D running on 0.0.0.0:1666.

To stop this instance run:
  p4 -p localhost:1666 -u super admin stop

To get more information about your Perforce (Helix) environment, you can run:
  p4 set

You may also wish to contact our sales team to discuss setting up a free 30 day evaluation of the Helix (Perforce) server.

This will give you access to technical support, who can help get you up and running with the product.

Hope this helps,
Jen!


#4 BlueTigerAnimations

BlueTigerAnimations

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 09 February 2019 - 09:06 PM

Whoops, Sorry for the late reply! I was kinda thinking that there would be an Email notification if the post was approved :unsure:
but thanks to both of you! I managed to get it working :)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users