Jump to content


Moving local depot to network location NAS issues


  • Please log in to reply
2 replies to this topic

#1 jerjan

jerjan

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 15 April 2019 - 09:56 AM

Hi all,

I'm in a situation where I have to move a local depot on a windows server to a new network location NAS storage.
In order to do this I have copied said depot onto the NAS storage and changed the depot map path accordingly.
//nas/projects/depots/depot/...
depot being the actual depot.

Essentially what I tried to do was method2 on this page.
https://community.pe.../s/article/2559

Now trying to get a revision I receive an error.

no files updated
1 error reported
Librarian checkout //nas/projects/depots/depot/somefile.txt failed.
open for read: //fsnasts421/team/projects/depots/depot/somefile.txt,d\1.631.gz: Access is denied.

side note;
I've tried this whole process on the server itself, copying the local depot keeping it relative to the server root.
This worked without any issues.
Somehow copying it outside the server root I can't get it to work.

Hopefully someone is able to assist me with this issue.
Thanks.

Regards,
Jer

#2 akwan

akwan

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 19 April 2019 - 09:42 PM

Sounds like the depot map path might need to be updated. This is the on system disk path that correlates to where files are actually stored. Not sure if I read that you altered the actual client-viewed depot pathing, or wanted to?

e.g.,

Original local path:

depot: Depot
depotPath: //depot/...
on disk: /mnt/local/depot/

New storage path:

depot: Depot
depotPath: //depot/...
on disk: /mnt/network/depot/

After rsync'ing the files and read/write/execute status to your new target (and ensuring the files were owned by the correct user), update the depot Map field to your new path.

To make things easier (particularly if all depots exist on the same storage), set the server configurable "server.depot.root" of the depot directory path (in this case, /mnt/network).

#3 Sambwise

Sambwise

    Advanced Member

  • Members
  • PipPipPip
  • 800 posts

Posted 19 April 2019 - 11:05 PM

open for read: //fsnasts421/team/projects/depots/depot/somefile.txt,d\1.631.gz: Access is denied.

At the risk of being overly reductive: have you checked the access permissions on your NAS?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users