Jump to content


p4 clone issues - "Change X performs a move/delete on ...."

clone history depth shallow

  • Please log in to reply
No replies to this topic

#1 wg_bhiggerson

wg_bhiggerson

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 30 May 2019 - 08:15 AM

Hi,

I've been experimenting with using p4 clone for a local dev server.

I am attempting to restrict the depth using -m 1, but then I receive the following error.

Change N performs a move/delete on _FILENAME_#2, but the parameters of this fetch, push, or zip command include only part of the full action. Specify a wider view to include both the source and target of the change, or specify a narrower view to exclude both the source and target of the change.

From my research, it appears others have hit this problem. I tried with -m 2 as suggested in [this](https://forums.perfo...r-after-update/) thread but that didn't work. The only option that _seemed_ to work (or at least, didn't fail immediately like the others) was with no depth restriction at all. As one could predict, with a single-depth size of 10s of GBs, this leads to quite a large and cumbersome local server.

I've tried various depths up to 10, but it hasn't helped. The files that come up are usually ~3 revisions of history, where #2 is a rename and #3 is a separate delete.

I am open to suggestions on how to perform a shallow clone that works in _all_ circumstances, different combinations of renames/deletes, and so on.

Thanks!





Also tagged with one or more of these keywords: clone, history, depth, shallow

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users