Jump to content


No files to submit error when wildcard is used in the stream paths

stream paths wildcard error submit

  • Please log in to reply
5 replies to this topic

#1 whyummi

whyummi

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 25 July 2019 - 11:02 AM

Hi,

I have encountered this strange error and since I didn't find anything useful in documentation, I would like to know if this behavior is a feature or a bug. The problem is that when I try to submit a file from a stream client and this file is mapped with use of * wildcard I got following error:

//TESTSTREAM/development/Pipfile.lock - warning: cannot submit from stream //TESTSTREAM/path_test client
No files to submit.

The problem occurs only when I use * wildcard for including files from root directory. When * wildcard is used with combination of folders for deeper paths, the submit succeed, as example:

Stream paths settings:
Paths:
		exclude ...
		share sources/*
		share *

Client content:
D:.
│ p4config.txt
│ Pipfile
│ Pipfile.lock
│ superprogram.py
│
└───sources
		project1.py
		project2.py
		project3.py
		project4.py
		project5.py
		project6.py

Submit will pass for any file in sources folder but will fail for any root located file.

When I map files like following:
Paths:
		exclude ...
		share sources/*
		share *
		share Pipfile.lock

The submit of Pipfile.lock will succeed.

I am using Windows client and Windows Perforce server (Server version: P4D/NTX64/2019.1/1796703 (2019/04/30))

#2 Sambwise

Sambwise

    Advanced Member

  • Members
  • PipPipPip
  • 927 posts

Posted 25 July 2019 - 06:53 PM

Quote

//TESTSTREAM/development/Pipfile.lock - warning: cannot submit from stream //TESTSTREAM/path_test client

This is suspicious -- my assumption is that there's some tricky virtual stream and/or import thing going on here that's being obscured because I can only see half of the picture.  Could you copy and paste in BOTH of those stream specs (development AND path_test) in their entirety so we can see what the relationship between them is?

#3 whyummi

whyummi

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 26 July 2019 - 08:51 AM

Specs for development stream:
Stream: //TESTSTREAM/development

Update: 2019/01/03 13:19:06

Access: 2019/01/03 13:19:06

Owner:  robot.obibok

Name:   development

Parent: //TESTSTREAM/mainline

Type:   development

Description:
		Created by robot.obibok.

Options:		allsubmit unlocked toparent fromparent mergedown

Paths:
		share ...

Specs for path_test stream:

Stream: //TESTSTREAM/path_test									   
																	 
Update: 2019/07/24 15:44:01										  
																	 
Access: 2019/07/24 15:41:30										  
																	 
Owner:  robot.obibok												 
																	 
Name:   path_test													
																	 
Parent: //TESTSTREAM/development									 
																	 
Type:   virtual													  
																	 
Description:														 
		Created by robot.obibok.									 
																	 
Options:		allsubmit unlocked notoparent nofromparent mergedown 
																	 
Paths:															   
		exclude ...												  
		share sources/*											  
		share *						   
              

My client spec:

Client: robot.obibok_IDK300-1064_path_test_542

Update: 2019/07/24 15:44:08

Access: 2019/07/26 09:53:09

Owner:  robot.obibok

Host:   IDK300-1064

Description:
		Created by robot.obibok.

Root:   D:\P4_workspace\robot.obibok_IDK300-1064_path_test_542

Options:		noallwrite noclobber nocompress unlocked nomodtime normdir

SubmitOptions:  submitunchanged

LineEnd:		local

Stream: //TESTSTREAM/path_test

View:
		-//TESTSTREAM/development/... //robot.obibok_IDK300-1064_path_test_542/...
		//TESTSTREAM/development/%%1 //robot.obibok_IDK300-1064_path_test_542/%%1
		//TESTSTREAM/development/sources/%%1 //robot.obibok_IDK300-1064_path_test_542/sources/%%1


#4 Sambwise

Sambwise

    Advanced Member

  • Members
  • PipPipPip
  • 927 posts

Posted 26 July 2019 - 02:40 PM

Try removing the unnecessary "exclude ..." from the Paths of the virtual stream, on the off chance that's confusing things.  But the generated client view looks like it SHOULD work...

If that's not it, you'll need to report the bug to support@perforce.com -- probably some kind of edge case in submit.

#5 whyummi

whyummi

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 29 July 2019 - 11:56 AM

Removing the "exclude ..." from virtual stream spec works. Now every file from client root folder can be submitted with no errors. So "exclude ..." and "share *" cannot be included both in stream spec. Thanks.

#6 Sambwise

Sambwise

    Advanced Member

  • Members
  • PipPipPip
  • 927 posts

Posted 29 July 2019 - 04:11 PM

Glad to hear that fixed it!

You don't ever need to start a stream with "exclude ..." because nothing is included implicitly -- an "empty" stream includes nothing.  So if you only want to include * then just make your only path share *.





Also tagged with one or more of these keywords: stream, paths, wildcard, error, submit

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users