Jump to content


Could not connect to Swarm. 'Connection refused'

Swarm Connection Logs

  • Please log in to reply
8 replies to this topic

#1 aaron_vnmr

aaron_vnmr

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 26 July 2019 - 05:52 PM

Hello,
I'm trying out HelixCore and I am attempting to use it with Swarm (running on OVA, host is windows 10). When I try to connect P4V to Swarm I receive the following error message:

"Could not connect to Swarm. 'Connection refused'   - See P4V's log file for more information."

I've looked in the log file for P4V, but I didn't find any information in the log file. What might I be doing wrong?

Regards,
Aaron

#2 Domenic

Domenic

    Advanced Member

  • Members
  • PipPipPip
  • 102 posts

Posted 26 July 2019 - 11:09 PM

Did you set the P4.Swarm.URL property on the server to point to your Swarm instance? If you didn't or aren't sure, check out the help file at http://your_url/docs...tegration.html.

#3 aaron_vnmr

aaron_vnmr

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 29 July 2019 - 04:57 PM

Yes. That property was set. I checked it like so:

C:\Users\name>p4 property -l -n P4.Swarm.URL
P4.Swarm.URL = https://[my url]

#4 p4rfong

p4rfong

    Advanced Member

  • Staff Moderators
  • 343 posts

Posted 29 July 2019 - 11:09 PM

Make sure you connect using the name specified in the config.php file and not the IP address.

#5 aaron_vnmr

aaron_vnmr

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 02 August 2019 - 09:33 PM

Unfortunately that didn't work. By name I'm guessing you meant the host name?

#6 p4rfong

p4rfong

    Advanced Member

  • Staff Moderators
  • 343 posts

Posted 03 August 2019 - 01:55 AM

I did mean host name.  Are you able to see the config.php file?
Can you ask the affected user to:

1. Open a windows cmd prompt from P4V->Right click over any folder in a workspace ->"Open Command Window here". This is make sure the Perforce environment is set in the cmd window.
2. Exit P4V
3. In the command windows run "p4 logout -a"
4. In the command window run "p4 login -a"
5. Open P4V again and check if it now connects to Swarm

Also can you have them check that P4V does not generate host-specific tickets:

P4V->Edit->Preferences, Connections, make sure that "Use IP-specific tickets when loggin in" in unchecked

#7 aaron_vnmr

aaron_vnmr

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 05 August 2019 - 07:15 PM

I was on the phone with a solutions engineer and there were a number changes we tried. In the end we changed the hostname to 'localhost', created a 'swarm' user in the OVA linux instance, then gave the user a password. After this the old error message went away, but a new error message "Could not connect to Swarm. 'Host requires authentication'" appeared.

Then I used p4 logout -a and then p4 login -a and now it connects to Swarm.

Thank you!

#8 p4rfong

p4rfong

    Advanced Member

  • Staff Moderators
  • 343 posts

Posted 05 August 2019 - 07:44 PM

Thanks for sharing your solution!

#9 aaron_vnmr

aaron_vnmr

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 05 August 2019 - 07:50 PM

Your welcome!



Also tagged with one or more of these keywords: Swarm, Connection, Logs

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users