Jump to content


P4 sync does not sync "all files up to date"

p4 client sync

  • Please log in to reply
No replies to this topic

#1 rbeadevops

rbeadevops

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 22 September 2019 - 04:45 PM

Hi all,

I have had cases where p4 sync does not sync to latest file(s) and reports " ... all file(s) up to date". I have resolved this in the past by
p4 sync ...@0
then
p4 sync -f ...#head
.

This time it was different. Running the above worked once, but every other subsequent sync just reported "...all file(s) up to date."

I have worked around for this issue by creating a new workspace, and sync seem to be working ok now. I was in another forum before it was suggested to reach out in here. I would still like to know how to fix this rather than having to recreate a workspace.

As far as I know the only change that was made was, the perforce administrators set limits on the account as our code p4 grep was hitting the server too hard. We have since removed that code and according to them they have removed the limits they added to the account we use to p4 sync with. Even if the limits remained, with our improvements p4 sync is only a fraction of what the limits were set to.

Setup:

- all developers use their windows p4v client to submit changes
- another team administers the perforce server (and responds unfortunately super slowly)
-our team supports the linux buildbox where p4 client commands are execute as part of the build pipeline.
- on our linux buildbox we run p4 sync, and if changes are detected we kick off a build

Details:

I have an odd issue of my
p4 sync /...
always returns

Quote

- file(s) up-to-date
.

This started happening intermittently about 2 weeks ago, then slowly progressed to 100% not working ie p4 sync does not pickup any changes.
If I run
p4 changes -m5
Enter password:
User <p4user> logged in.
Change 1523039 on 2019/09/19 by *********************************************online fix read me info'
Change 1523038 on 2019/09/19 by *********************************************config ids to Part'
Change 1523037 on 2019/09/19 by **********************************************pending* 'Created item-definition cache f'
Change 1523036 on 2019/09/19 by ********************************************* '<saved by Perforce> '
Change 1523035 on 2019/09/19 by ********************************************* '<saved by Perforce> '

P4 changes did show the file(s) properly that were pending to be submitted or that had been submitted.
Ran p4 sync /... and got the "all files up to date" response.
I have performed the following steps a few times now
  • cd
  • p4 sync …#0
  • rm -rf *
  • p4 sync -f …
This then syncs all the files successfully. I am using this as part of my automated build pipeline so I can't be having to do the above manually. From what I know we should not be using
p4 sync -f
all the time as a default.

btw I did perform
export P4CONFIG=~/.p4settings; /bin/p4 login < ~/.p4p; p4 workspace

and validated the views all parameters are OK.
After successfully submitting changes via p4v (and others on my team as we have done thousands of times) I run
p4 have
and file versions displayed had not been updated.

My build pipeline has worked for years. I am lost as how to resolve this. Any pointers are greatly appreciated.





Also tagged with one or more of these keywords: p4 client, sync

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users